FX30S latest software

I am new to FX30S software development, and it does seem very confusingly organized.

We have 2 products:

  1. First one uses the FX30S LTE & 3G models (LTE in one region, 3G in another). I want to update the firmware for these, and run my own rootfs and application. Is the link below the right place to download the firmware components for the 3G model?

Where can I find the firmware for the LTE model? Is it the CatM firmware I should be using from the same page?

  1. Am I correct in understanding that to build my own rootfs/kernel for the FX30S, I will need to install leaf to pull the source code? This process seems to have changed since older releases, is this correct?

  2. Second product uses the WP8548 and 77xx in 2 different regions. Where can I get the latest FW and sources for these - is it the link below?

Appreciate any directions to these seemingly simple questions, I was not able to answer them confidently on my own.


Hi @karthick.ng

  1. The following FX30S variants are currently available:
    · Penta-band HSPA+ (3G) (WP8548)
    · LTE Cat-M1/NB1 (WP7702)
    You can get FX30S 3G firmware packages here : FX30S 3G firmware packages
    and FX30S LTE Cat-M1/NB1 firmware packages here: FX30S LTE Cat-M1/NB1 firmware packages

  2. No, You don’t install leaf. Please refer to Legato Yocto for more details.
    Leaf is a development workspace manager designed to download, install, and configure your development environment for Legato. leaf

  3. You can get the latest FW and sources for WP8548 module here:WP8548 & WP75xx Firmware
    and for WP77xx module here: WP77xx Firmware

Please help to tick “Solution” if your question is answered.

Hi Donald,

Thanks very much for your quick response. I will follow the links you sent.

One folllow on question- why is the FW different for the FX30S vs the module? Is there another controller in the FX30S, or is it for the additional hardware support? Can you point me to documentation that reveals these differences?

Also, the Legato link is for a 2017 build. How come the sources are that old when the last binary release seems be dated Jun 2020?

Hi @karthick.ng

What module type on your FX30S? WP8548 or WP7702 module?
You can check it on the device label or use ATI3 command.

FX30S 3G firmware package for FX30S(WP8548), FX30S LTE Cat-M1/NB1 firmware package for FX30S(WP7702)
You can refer to this document. AirLink FX30S User Guide

All source code and firmwares for FX30S here https://source.sierrawireless.com/resources/airlink/software_downloads/fx30-firmware/fx30-firmware/#sthash.mqdI3f2B.WmE2m8jk.dpbs

Hi @karthick.ng,
The prebuilt full binary images are available at source.sierrawireless.com where as leaf is a package management tool that provides a development environment via VS Code or linux command line.

Depending on what you want to develop, you can pull the full yocto source environment or just the Legato framework.

The FX30 image is different from the WP module image in the following:

  1. The FX30 image uses the WP module image as it’s base. ie, the R11.0.0.007 FX30 image is built on top of the WP R11 release
  2. There are additional kernel drivers and fixes to support the FX30 hardware peripherals such as RS485, extra GPIO
  3. There are additional Legato fixes. For the FX30 R11.0.0.007 release, Legato 18.09.5 was released compared to the module R11 release that contains Legato 18.09.2
  4. There are changes in the root file system for similar reasons above. ie, bug fixes, hardware support


Hi @Donald

The link you shared does not have source package for R17 for the FX30S 3G. I downloaded the source from https://source.sierrawireless.com/resources/legato/legatolinuxdist/#sthash.u2BywNRH.dpbs . Can you confirm this is the right source code?

I tried building this following the instructions in the meta-swi-extras/README.build file. However, I am unable to clone meta-swi and meta-swi-extras repos from https://github.com/MalvernPark/meta-swi.git as mentioned in the instructions. I tried building with the downloaded source code from above, but that build fails with an “ExpansionError” when parsing the kernel.

Are the steps above correct to build yocto or is something wrong?


Thanks, @cchenry that makes sense.

I ran into a problem building the sources, see my previous post. Appreciate any suggestions or pointers.

@Donald As I mentioned earlier in this thread the release at https://source.sierrawireless.com/resources/airlink/software_downloads/fx30-firmware/fx30-firmware-3g/ does not provide source for R17.

I followed the link you gave in the first answer to download the source code. Apparently, that is the wrong one.

No, You don’t install leaf. Please refer to Legato Yocto for more details.

Can you please point me to source code for R17 for the FX30S 3G?

Hi @karthick.ng,
The FX30 3G R17 source code is available through leaf with identifier: swi-fx30-3g_1.0.1