Release 16.1 + Legato 18.06.4 on FX30

#1

Hello,

Does the release “Release 16.1 + Legato 18.06.4” work on the FX30 3G? This is the latest stable release listed in leaf for the wp85xx chipset.

This release doesn’t mention the FX30 in its release notes. Is it only compatible with non-FX30 wp85xx devices?

Is Release 14.0 the latest to be compatible with the FX30 3G?

Thank you

#2

Hi mtaylor,

The FX30 3G (WP8548) does not currently support R16.1 with Legato 18.06.4.

You’re correct, the latest release is R14.0.4.002 with Legato 16.10.1.m3

BR,
Chris

1 Like
#3

OK, thank you @cchenry!

#4

I’m using an FX30S 3G. Using leaf I grabbed the latest wp85 releases. Everything works great except for /dev/ttyHS0. But if I run on R14.0.4.002 with Legato 16.10.1.m3, the “ethernet” connection on 192.168.2.2 between ubuntu & the device can’t stay up for a minute. (And yes, I don’t have modemmanager on my Ubuntu 16 box). What to do? When will the FX30S get the current release?

#5

Hi reckstein,

Could you please clarify, is your ssh connection dropping? Can you supply any command line output or logs? Is your device boot looping?

Have you manually edited any files?

The USB network interface is quite stable.

The next targeted release for the FX30 3G is the WP R17, however the date is still TBD.

BR,
Chris

#6

I have no idea what was dropping & logread doesn’t help after a reboot. If I have to downgrade to R14.0.4.002 with Legato 16.10.1.m3, I’ll install the windows driver & maybe can see what’s going on using the serial port. (On the other hand, I’m not the first person to point out the problem.)

I have a whole leaf environment set up & do everything by command line. Do I now have to throw out my environment & work thru DevStudio? Cuz last time I used DevStudio it wasn’t supporting the latest stuff for the FX30S. And the last time I tried to do this, I recall that setting up the right toolchains, etc, was non-trivial. Hence, leaf.

Randi

#7

Hi Randi,

In case you did want to use DevStudio, here are some links I found that helped with the non-trivial configuration.

Here are the basic instructions (see the comment by @benrey): Starting out with the FX30S and questions abound

If you’re using a later version of Ubuntu (I’m using 18.04 LTS) you’ll need to do what is in this thread: https://forum.legato.io/t/building-16-10-1-m3-for-fx30-r14/3555?u=mtaylor

Also, I found out the hard way that even though the compiler toolchain will ask where you want to install it, leave it at the default location (under “/opt/swi”). If you put it elsewhere, some Legato scripts break.

Not trying to push DevStudio on you. Just wanted to collect these links/tips here because answers to custom FX30 development issues are hard to find.

#8

My thanks to Michael Taylor for his tips & to @benrey for the instructions in order to get the official FX30S on DevStudio (tho the build & install button does the build nicely & can’t install the app – complains about some missing binary stuff – I dunno. But command line ‘app install’ works fine.)

So the problem with connection issues on the USB ethernet connection has gone away. Perhaps my earlier attempts were on an earlier version.

And I do have a working serial port now.

However, the modem wasn’t able to get a signal anymore. The same code worked on the newer build. :frowning: I will start a new forum entry for that.

Randi