FX30 ssh not working

Hi,

I am new to FX30 and am unable to connect to it via ssh root@192.168.2.2, but the connection is timed out… Can you pls suggest how to connect to the module.

I am running this against a Linux host machine, connected to the device through the USB port.
screenshot

From screen capture, usb0 has not assign any IP address.

Please try set IP manually then try again, i.e.

sudo ifconfig usb0 192.168.2.3
ping 192.168.2.2 -c2
ssh root@192.168.2.2

Hope it helps.
Thx

Thanks for the suggestion… When I try to ping, the statistics show 100% packet loss.

$ ping 192.168.2.2 -c2
PING 192.168.2.2 (192.168.2.2) 56(84) bytes of data.
From 192.168.2.3 icmp_seq=1 Destination Host Unreachable
From 192.168.2.3 icmp_seq=2 Destination Host Unreachable

— 192.168.2.2 ping statistics —
2 packets transmitted, 0 received, +2 errors, 100% packet loss, time 999ms
pipe 2

Sorry, I don’t have FX30 but may I ask the FW / package version your FX30 is running?
You may check via USB AT port or UART interface.

Thx

FX30 firmware release version is R13.1.2.004

I get the below response trying the AT Command - AT!PACKAGE?
1103232_9906770_FX30S_07.11.22.00_00_AirLink_001.002_000

Thnx

Thanks sreeramya.

I believe it should at least able to ping…

Are you running Linux in virtual machine? If yes, maybe similar case below, or can you try different host PC?

Do you have serial or ethernet interface on your FX30?
Thx

Hi lotam,

I am using a Linux PC to communicate with the FX30 serial variant … Tried with a different host as well… Didn’t find any luck.

I tried to install windows drivers and connect the device. However I cannot see the IP address being assigned to the device even in case of Windows host.

Thnx