FX30 Radio Off

I’m using an FX30 with a Verizon SIM card, connected to it from Windows 10.

After rebooting, the device was in low power mode. I attempted to return to full power as follows
at+cfun=1 is not a supported operation
at+cfun=1,1 reboots the module
at+cfun=7 seems to have exited low power mode
(the other ‘at+cfun=?’ commands were not useful, one put it in factory test mode, the others did nothing)

From at!gstatus? the mode us OFFLINE. Through SSH, cm radio status shows the radio is OFF.
The command ‘cm radio on’ does nothing.

How can I ‘enter’ full-power, or normal operating mode? How can I turn the radio back on?

Full at!gstatus? output below
Current Time: 1813 Temperature: 26
Modem Mitigate Level: 0 ModemProc Mitigate Level: 0
Reset Counter: 2 Mode: OFFLINE
System mode: LTE PS state: Not attached
LTE band: No band LTE bw: Unknown
LTE Rx chan: 0 LTE Tx chan: 4294967295
LTE CA state: ACTIVE LTE Scell band:B8
LTE Scell bw:1.4 MHz LTE Scell chan:0
EMM state: NULL —
RRC state: RRC Idle
IMS reg state: No Srv

PCC RxM RSSI: 0 RSRP (dBm): 0
PCC RxD RSSI: 0 RSRP (dBm): 0
SCC RxM RSSI: 0 RSRP (dBm): 0
SCC RxD RSSI: 0 RSRP (dBm): 0
Tx Power: 0 TAC: 1918 (6424)
RSRQ (dB): -3191 Cell ID: 00000000 (0)
SINR (dB): 0

Full cm radio status below
Power: OFF
Current Network Operator:
Current RAT: Not available
Status: Not registered and not currently searching for new operator (LE_MRC_REG_NONE)
Signal: No signal strength (0)
PS: Packet Switched Not registered (LE_MRC_REG_NONE)

Hi Daniel,
Any chance it is the OS Windows 10 forced airplane mode?
Please check connection settings or the Ethernet/Cellular button on the toolbar (next to the clock).
Hope it helps.
Thanks

Hi lotam,
The OS is not in airplane mode. From the toolbar menu I see that airplane mode is turned off. It also says “Cellular, Turned Off”.
In the settings menu, I see that “Let Windows manage this connection” is not checked and it is grayed out - I cannot check the box. To be thorough, I connected the module to a second Windows 10 PC; “Let Windows manage this connection” is checked, also not in airplane mode, but I have the same result.

Can you confirm that “at+cfun=7” and “cm radio on” are the correct commands to set the device to normal full-power mode, and turn on the radio?

Thank you.

Thanks Daniel.
So are you saying the “Cellular” icon is also gray out and you cannot click to enable?
image
If yes, sorry for wrong guess then maybe something on FX30.

Yes, “cm radio on” or AT+CFUN=1 normally used to set normal online mode.
Please also share response of below which may tell the cause of off:
AT!PCINFO?
AT!PRIID?
ATI
ATI8

By the way, I also saw you have another post about FX30 but relate to VZW…
May I clarify that you have two FX30, one stay radio off (this post) and another one can “online”?

Thank you.

Hi lotam,

Correct about the cellular icon in Windows.

My other post about the FX30 with VZW is about the same device, but that issue occurred first. While trying to fix that issue, the issue in this post occurred.

It may be solved now, but I don’t know why. If I disconnect the cellular antenna from the FX30, the command “at+cfun=1” seems to work, and the radio turns on. I attached the antenna, and it still says ‘online’.
Do you know why this might be?
(the issue from my other post persists though)

For those commands

  • AT!PCINFO?
    State: Online
    LPM voters - Temp:0, Volt:0, User:0, W_DISABLE:0, IMSWITCH:0, BIOS:0, LWM2M:0, OMADM:0, FOTA:0
    LPM persistence - None

  • AT!PRIID?
    PRI Part Number: 9907957
    Revision: 001.000
    Customer: FX30-Series

Carrier PRI: 9999999_9907618_SWI9X06Y_02.16.06.00_00_GENERIC_001.028_002

  • ATI
    Manufacturer: Sierra Wireless, Incorporated
    Model: FX30(WP7702)
    Revision: SWI9X06Y_02.16.06.00 7605a6 jenkins 2018/06/20 17:56:12
    IMEI: 354723090111823
    IMEI SV: 2
    FSN: VU844685050210
    +GCAP: +CGSM

  • ATI8
    Legato Ver: 18.06.1_03c5394b4c271c054ae58a494f160e37
    Yocto Ver: SWI9X06Y_02.18.05.00 2019-01-29_11:20:10
    OS Ver: Linux version 3.18.44 (jenkins@CAKEL-EV-ALBLD2) (gcc version 6.2.0 (GCC) ) #2 PREEMPT Tue Jan 29 11:21:07 PST 2019
    LK Ver: 1.3.0_838aec2863
    RootFS Ver: SWI9X06Y_02.18.05.00 2019-01-29_11:20:10
    UserFS Ver: unknown
    MCU Ver: 002.009

and at!gstatus?
!GSTATUS:
Current Time: 333 Temperature: 27
Modem Mitigate Level: 0 ModemProc Mitigate Level: 0
Reset Counter: 1 Mode: ONLINE
System mode: LTE PS state: Not attached
LTE band: B13 LTE bw: 10 MHz
LTE Rx chan: 5230 LTE Tx chan: 4294967295
LTE CA state: INACTIVE
EMM state: Deregistered Attaching
RRC state: RRC Idle
IMS reg state: No Srv

PCC RxM RSSI: -82 RSRP (dBm): -117
PCC RxD RSSI: -82 RSRP (dBm): -140
Tx Power: 0 TAC: 6A00 (27136)
RSRQ (dB): -17 Cell ID: 019F1B03 (27204355)
SINR (dB): -3.8

Hi there,
I suspect your modem has PSM enabled by accident.
Try disabling by:
AT!CPSMS=0

BR,
Chris

Hi Chris,

Trying that command (and any variation I could think of) returns ERROR, but the device also reliably starts in normal/full-power mode now (prior to the command).

For some reason, it appears the solution was to unplug power and both antennas, let the device sit for a few minutes, and reboot - only reattaching the antennas after issuing “at+cfun=1”.
(It doesn’t inspire much confidence, but the radio is on now…)

Best,
Daniel

Hi Daniel,
When PSM is enabled, the module attempts to determine the radio receive strength and turn off if it isn’t sufficient, saving power.

There might be a bug in R9.1.1.013 (which might also carry forward in R11) in which PSM has become enabled, even if CPSMS returns ERROR.

Could you please try this procedure:

  1. Turn off the radio: AT+CFUN=0 and then reboot
  2. Turn off PSM: AT+CPSMS=0 and then reboot again
  3. Enable the radio: AT+CFUN=1
  4. Confirm PSM is disabled: AT+CPSMS?

Once PSM is confirmed disabled, I hope you won’t observe the issue with the radio turning off any longer.

BR,
Chris

Hi Chris,

CPSMS no longer returns an error - nor does CFUN, and PSM reports as disabled (+CPSMS:0,“01100000”,“00000000”)

Thank you for all of your help.

1 Like