[FX30] Changing the USB IP address does not fully reconfigure the DHCP server


#1

Hello,

I some time have to change the USB IP address to 192.168.3.2 when I’m using the Fx30 connected (by its ETH0) to a network using the subnet 192.168.2.XXX.
To do this, I’m using the console command: “$> configEcm on target 192.168.3.2 host 192.168.3.3 netmask 255.255.255.0”

I’m using an Fx30 with the firmware R13.1.3.001.

After this command, the USB link correctly responds on the new IP address (192.168.3.2), but I have seen the Fx30 DHCP server (dnsmasq module) responding on the network 192.168.2.XXX. All clients listening to the Fx30 DHCP server endup with the Fx30 as their gateway which is wrong.
I need the Fx30 DHCP server to respond on the USB interface ONLY.

I see on that the new configuration (the one with the subnet 192.168.3.XXX) is added to the configuration file /etc/dnsmasq.d/dnsmasq.ecm.conf. the old configuration (the one with the subnet 192.168.2.XXX) should be removed.

I propose to modify the /mnt/legato/system/bin/configEcm script to clean the DHCP configuration file before adding into it the new configuration (in the config_dhcp() function).

Thanks to give me your opinion on this modification.

Best regards, Christian.


#2

Additional information.

Here is the dnsmaq configuration file after the configEcm network change:

root@fx30s:~# cat /etc/dnsmasq.d/dnsmasq.ecm.conf

dhcp-range=interface:usb0,192.168.2.3,192.168.2.3,12h
dhcp-option=usb0,3
dhcp-option=usb0,6
dhcp-range=interface:usb0,192.168.3.3,192.168.3.3,12h
dhcp-option=usb0,3
dhcp-option=usb0,6

Maybe adding the parameter “–interface=usb0”, on the dnsmasq start scrip, would be better to avoid the DHCP server responding on other interfaces.

Regards, Christian.


#3

Hi Christian,
Thanks for your suggestion! Changing the USB IP address isn’t a supported feature but I’m glad you figured it out.

BR,
Chris