Firmware needed for vodafone

I have Em7455 with SWI9X30C_02.33.03.00 and SWI9X30C_02.32.11.00 firmware with GENERIC, AT&T, ROGERS, SPRINT & VERIZON PRIs installed with VERIZON as the default.

I can connect to “tele2” network in Netherlands without any problem (without changing any firmware settings), but can’t connect to vodafone Netherlands. Does it require vodafone firmware?, or since the current firmware version is higher than vodafone firmware version, it doesn’t matter? Please advice.


Hi @vijuj,
Did you set the APN for Vodafone on the module? It needs the APN to attach the network. Generically, it is always the best to use the carrier specific firmware to avoid what potential changes/problems
Please share any concerns you have. If my response answered your question please click the Solutions under my response. This ensures others can benefit from the topic. Thanks in advance for your help with this!

Hi @Vianney,

I did set the APN for vodafone, and it still did not connect. Next I will try to install vodafone specific firmware and see if that helps. As I mentioned before, I was able to use another provider (tele2) without any problem.



The short answer is no you don’t need a VF specific firmware, the generic firmware works pretty much on all operators across Europe, it only matter when you go to restrictive markets like the US, Japan, Korea, etc.

When you say you can connect to tele2 in the Netherlands do you mean you are able to use a T Mobile SIM and connect to its network there and you are now trying to use a Vodafone SIM and connect to its network? As Vianney has said all you need to do is make sure the APN for the respective SIM card is set correctly in CID 1 (at+cgdcont=1,“IP”,“xxxxxxx”).



Thank you for the response. Finally I got vodafone SIM working without installing vodafone firmware (I believe it used the generic firmware). BUT I had to set the AT!IMPREF to vodafone. Then it started working.

Regarding tele2 - it uses T-Mobile network, but the APN is tele2 specific. the tele2 SIM worked without changing the IMPREF. It was set to VERIZON at that time and it worked.

So that answered my question. Vodafone worked with Generic firmware (but I had to set AT!IMPREF to vodafone)

Thank you