Fasttrack Supreme 10 can not receive +CDS


#1

Hi ,

I am using Fasttrack Supreme 10 modem in Singapore and configured with following settings:

(23/1/2009 11:55:45 AM) (Tx): AT+CREG?
(23/1/2009 11:55:47 AM) (Tx): AT
(23/1/2009 11:55:46 AM) (Rx): AT+CREG?
(23/1/2009 11:55:46 AM) (Rx): +CREG: 0,1
(23/1/2009 11:55:46 AM) (Rx): OK

(23/1/2009 11:55:47 AM) (Tx): at+cmgf=1
(23/1/2009 11:55:47 AM) (Tx): at+cnmi=2,2,0,1,0
(23/1/2009 11:55:47 AM) (Tx): at+csmp=49,167,0,241
(23/1/2009 11:55:47 AM) (Rx): AT
(23/1/2009 11:55:47 AM) (Rx): OK
(23/1/2009 11:55:47 AM) (Rx): at+cmgf=1
(23/1/2009 11:55:47 AM) (Rx): OK
(23/1/2009 11:55:47 AM) (Rx): at+cnmi=2,2,0,1,0
(23/1/2009 11:55:47 AM) (Rx): OK
(23/1/2009 11:55:47 AM) (Rx): at+csmp=49,167,0,241
(23/1/2009 11:55:47 AM) (Rx): OK

I was able to receive “+CDS” message.

But when my customer tested the modem with the same setting configuration as above in “Brunei Country” .
I was Not able to receive “+CDS” message.

What could be the reason for this, need assistance.

Many Thanks.

Regards,

Wielly


#2

Hello,

I am wondering if someone can help with my problem that
the sms modem did not received +CDS (Note: message was correctly delivered"") after I send +CMGS to my mobile phone.
I received the message on my mobile phone, but I could not see any +CDS .

My code :

AT+CNMI=0,1,1,1,0 [Note: “SMS-DELIVERs are directly stored, SMS-STATUS- REPORTs are displayed”]
OK
AT+CSMP=17,169,0,0 [Note: “SMS-SUBMIT message with a validity period (one day)”]
OK
AT+CMGF=1 ” ” [Note: “Text mode to send a Short Message”]
OK

AT+CMGS=+62601290800 [Note: “Send a SMS-SUBMIT to mobile phone”]

test

+CMGS: 5


My Reference for code above : rfsolutions.co.uk/acatalog/D … mmands.pdf (page 220)

my questions are:

  1. Is the configuration correct ?
  2. Could it be SIM dependent for each country ? if yes , do I need to contact my Service Provider in my country asking for message delivery status (+CDS) ?

Many Thanks for a prompt reply

Regards,

Wielly