EM9191 5G Support

I am using the EM9191 cellular module, but I am not able to get any 5G connection. 4G connection is working though.

When I send the AT Command AT!NRINFO? , all the fields are empty.


I want to use the AT Command AT! DASUB6TECHACT=1 to start the 5G-Sub6 technology, but I get an ERROR output when I try to put the modem in FTM with AT Command AT!DAFTMACT .

Using mmcli, I have tried using the modes is allowed: 4g, 5g; preferred 5g and allowed: 5g, preferred: none . When the mode is set to allowed: 5g, preferred: none, I cannot connect to the mobile broadband, it just timesout.

Also, in the hardware section, it looks like 5gnr is supported.


Here are a few details about my setup:

  1. OS: Ubuntu 20.04.3
  2. Carrier: T-Mobile
  3. mmcli version: 1.16.6
  4. Successfully Installed MBPL Drivers [Link]: MBPL_Drivers_USB_R23_ENG2-src.tar

Could I get some assistance for this issue?

Hi aiden.chan,

Which mode does your network operator support, NA or NSA? If you don’t have this info, please ask the operator for this.

Some commands require password before executing them. So please enter the password by command AT!ENTERCN=“A710”

Could you help to provide the result of the commands below?
AT!ENTERCN=“A710”
AT!SELRAT?
AT!SELRAT=?
AT!BAND?
AT+COPS?

Thanks,

Hi jerdung,

Thanks for your help on this issue. My network operator is using NSA.
Here is the output from the AT Commands:

AT!ENTERCN=“A710”: ERROR

AT!SELRAT?

AT!SELRAT=?
selrat equal

AT!BAND?
AT band

AT+COPS?

Hi aiden.chan,

Sorry for my mistyping. AT!ENTERCND=“A710” is the correct one.

First, try to update the latest FW here:
https://source.sierrawireless.com/resources/airprime/software/em919x/em9-approved-fw-packages/#sthash.coc51d4j.dpbs

Then, set AT!SELRAT=00 for automatic mode then try again. After module attaches to the network, please show the result of AT+COPS?

Thanks,

Hi jerdung,

Thanks for the update, that is ok.
I am not sure how to update the FW, could you provide some instructions for this – any specific command or program needed?

Anyway, I gave the commands a try.
The AT!ENTERCND=“A710” is working for me.

The output from AT!SELRAT=00 : OK
The output from AT!COPS? : +COPS: 0,0,“T-Mobile”,7
I did not type anything afterwards, but I saw another output: +CCLK: “21/10/20,17:11:27-28”

You are running a quite old firmware (01.07.08), try updating to a newer one (e.g. 01.07.19).

The broken “AT!SELRAT?” output is triggered by an insufficient implementation, as you can see the “Modes supported” list from QMI is much longer than the list of allowed value from AT!SELRAT. Notable, there is no 4G+5G entry.

You can try resetting the Act modes by “AT!SELRAT=0”. This may help. Unfortunately, Sierra does not tell if the mode only refers to the anchor cell, or also affects EN-DC/NSA modes (i.e. LTE + 5GNR).

The “+COPS: …,7” output suggests your current environment does not have any 5GNR cells, or you are using an anchor cell/band which can’t be combined with an existing 5GNR cell (e.g. B3+n1). On the other hand, the output of AT+COPS is notoriously broken for the EM9191, I have seen it reporting “7” (LTE-only) and “13” (EN-DC) for the same network/location, even when EN-DC was active (according to AT!GSTATUS?).

Hi jerdung and stefan, thank you to both of you for your support.

I tried updating to the latest firmware for T-Mobile in Ubuntu 20.04.3 OS based on this guide:

But there was an issue with the download.

Unfortunately, now I am not able to connect to the modem anymore after trying this firmware update.
When I try to turn on the mobile connection, it turns off immediately.

I reset the operating mode with the below command:
qmicli -p -d /dev/cdc-wdm0 --device-open-mbim --dms-set-operating-mode=reset

Then, I restarted ModemManager and NetworkManager.

EDIT: I reinstalled the OS, and now I am able to send AT Commands, the ttyUSB1 port opened up.
Also attached the new mmcli -m 0 output: mmcli m 0 output.txt (4.1 KB)

Is there any way I can bring up the cellular connection?

I managed to solve the cellular connection issue by sending the AT Command “AT!RMARESET=1”.

However, I am still having the same issues with the firmware update, even after when updating the firmware to the GENERIC Carrier: SWIX55C_01.07.19.00.
The error message was: “error: unsupported download protocol”.

Any ideas on how to resolve this issue?