Connecting to private LTE network/AT commands/nas-network-scan

Trying to connect to a private LTE network. I have a drone made by another company that came with the EM9291 modem - I am coming over from their forms as it feels a little more modem-centric. I am having some issues connecting to my private network. I have successfully connected to other networks, and can confirm the modem is working.

most notably, I cannot even see the network with qmicli device=/dev/cdc-wdm0 --nas-network-scan

I know the network exists, as I have a cell phone with me that is connected to it. I have read through some posts here and their forms which have led me to AT commands. The two questions I have are:

  1. How do I issue AT commands? This drone company does not seem to have any examples of AT commands issued for this modem.

  2. What is the behavior of --nas-scan-networks? I tried to look for some documentation but could not find it. Does it only look for a certain subset of MCC/MNCs? Our network uses 001/01

I saw here that test networks generally don’t show up. Seems like AT commands are the way to rectify this?

how about using AT+COPS=?

Great suggestion, thank you. How do I issue AT commands? That was one of the questions in my post that I am still unsure of. Once I figure out how to issue these commands, I will try that.

Did you install MBPL USB driver?
/dev/ttyUSB0 should be enumerated for AT command

I do not see ttyUSB0 enumerated. This modem came as part of a drone from a third party. Their scripts are open source, and I see them enumerate ttyUSB0 for other modems, but it is not for the EM9291. I have a ticket out with them to inquire how the send the AT commands. ls /dev lists a bunch of tty#, but no TTYUSB#

Can you check dmesg?

dmseg_output.txt (162.1 KB)

What should I be looking for? Attached the full output for convenience

Can you install MBPL USB driver?

i don’t see your qcserial driver is enumerating anything

I will try to install that. Again this is a 3rd party drone, and I am fairly new to this project, so forgive some of my dense questioning… of all the links on that page, which one will I want and is there anywhere in particular I should install it? just on the drone or somewhere else relating to the EM9291?

you can install MBPL_DRIVERS_R35_ENG4-usb-src.tar

Okay, I unzipped the tar on the drone, but I get some make errors when trying to install. I know how to fix many of them but I am a little hesitant to install this in the event it messes something else up the devs of this drone have set up. Let me try to hear back from their devs first before I move forward

@jyijyi Tried to go thru with everything…

This is the output I receive

make -C /lib/modules/4.19.125/build M=/usb make[1]: Entering directory '/lib/modules/4.19.125/build' make[1]: *** No targets specified and no makerfile found. Stop. make[1]: Leaving directory '/lib/modules/4.19.125/build' Makefile:12: recipe for target 'all' failed make *** [all] Error 2

if it provides any clarity, I had to
mkdir /lib/modules/####/build
it did not exist before

You better ask the drone how to install

I am still working on getting these drivers installed, but I can see that the qcserial they are using does not have the SW EM9291 defined. its most recent definition is the the 7565. Once I get the driver working, I will be able to send AT commands to that port. I have seen a few other posts on here that I will have to dig up. You recommended using AT+COPS=? . What would the next steps be assuming my network appears? What would they be if my network does not appear? Note I know that the network is up because I have other phones connected to it

the goal is to see if AT+COPS=? returns the network scan result

1 Like

is there a path forward if it does not return my network?

does it work with public SIM card?
If yes, probably it really cannot see any operator when using the private SIM

Yes the drone works with a public SIM card. (I assume you mean something like a verizon SIM). Additionally, I have the SIMs needed for my private network in regular phones and they connect to my private network so I can confirm it is up