EM7565 stuck in qdownloader after flash


#1

Hello,

My problem begins with flashing firmware on my EM7565 to 01.07.02. After flashing, the card had an image mismatch. I entered the generic firmware command to flash back and I am now stuck at this qDL function. This is what it shows as in my device manager. I am unable to reach this via putty other than serial on it’s port.

The one click update fails and I am not sure how to restore the card at least to the previous working order.

Any help is appreciated, thank you.


#2

This thing is a brick


#3

Hello,

Under windows environment where at “QDLoader” status that means that module is waiting for firmware update because couldn’t boot at normal state. Have you tried installed under Linux or Ubuntu environment ? I believe that module still not at “brick” status where if under Ubuntu environment if you could see three (3) devices (/dev/ttyUSB0, USB1 and USB2" then that module could be recovered.

Regards


#4

I have not. I am able to reach via Putty or Huawei Terminal on windows but only in a serial connection. I am unsure how to load firmware images with Linux, could you point me to a handy how to? I do have a few routers running openWRT builds but was unable to see the em7565 there as well.

Thank you for your help.


#5

Hello,

I just an ordinary user where I’ve the same scenario on my MC7455 where under windows environment it shows only “QDLoader Port” while on Ubuntu environment it shows only “/dev/ttyUSB0” which means “diagnostic port”. I believe my MC7455 already at “brick” status. Hopefully your module still at “available” status for recovery. This such module has an internal security where it becomes "firmware"status where more then six (6) times frequently reset.

I believe another “expert” members would advice you how to recover your module.


#6

I received a EM7565 stuck in QDLoader today and now have a documented process for recover as well as update to the newest firmware. You can find the instructions on my GitHub.