EM7565 lost band 42 support with latest FW


#1

Hi,

We have an EM7565 module for about year, and we bought it specifically due to band 42 support. It worked on band 42 quite nicely, then I updated the FW to Revision: SWI9X50C_01.08.04.00 dbb5d0 jenkins 2018/08/21 21:40:11, and the modem never ever reregistered on our band 42 network.

After some reading, I found this in an attached document next to the firmware:

The band setting in the modem is:

at!band?
Index, Name
00, All bands

I also tried setting it to 06, Europe, does not helped.

This modem is completely useless to us without band 42 support. We are in the EU and have a license to use band 42. So it would be nice if someone can enlighten us how to get the band 42 support back on this modem.


#2

Hi,

This is a bit of (recent) history and circumstance.

The unit you got might have been an early prototype with old firmware, because it was it would have had everything enabled on it. In later revisions, when we started commercially shipping product, we had to restrict this band operation because FCC had not moved as fast as had been expected in terms of approving it.

So given the above the following applies.

  • FCC have now approved everything and it is enabled on all units currently being shipped.
  • For older units where it is not enabled there is a windows one click updater which updates the NV items in flash enabling the CBRS (42, 43 and 48) bands. You can get hold of this through your commercial channel (they will raise a ticket to us and we will send it to them, cannot post it on the forums).

Regards

Matt


#3

Hi Matt,

Thanks for the info. I contacted the company where we got our modem, so now I am waiting for them.

None the less, I am not sure why this tool cannot be shared on your website, or via this forum?


#4

I did some tests to regain the band 42 support, this is where I am now:

  1. First tried to restore the factory state:

AT!ENTERCND=“A710”
AT!IMAGE=0
AT!RESET

This was successful, but still the modem wont register with our network.

  1. Created my own band setup with only band 42 in it:

AT!BAND=10,“B42”,0,0000020000000000
AT!BAND=10
AT!RESET

The modem was registered successfully (01.00.02.00)

  1. Upgraded to 01.05.01.00, after upgrade again there is no band 42 support, creating my own band solved the issue again.

This is where I am now.

I noticed that from 01.05.01.00, I need to go to 01.07.02.00, before I can get to the latest one.

So this is a partial success. Will continue tonight.

@mlw by the way the company said they cannot send the tool you mentioned to me. In case I really need to use, I will need to send the modem back, which I find ridiculous.

MOD:

I continued on my journey, and upgraded to 01.07.02.00.
Of coarse, there was no band 42, but I noticed that AT!IMPREF? returns a “config name mismatch”:
preferred fw version: 01.07.02.00
preferred carrier name: GENERIC
preferred config name: GENERIC_002.004_001
current fw version: 01.07.02.00
current carrier name: GENERIC
current config name: GENERIC_001.028_000

 config name mismatch <--- !!!

In this case, the same firmware version needs to be flashed again, as this indicated some NVRAM compatibility issue.

I reflashed the firmware, and the “config name mismatch” error was gone.

Finally, I flashed the latest (01.08.04.00) firmware, which was a success (no reflash was needed), yet no band 42 support.

Now I set my band profile again (which was lost after the FW upgrades):

AT!BAND=10,"B42",0,0000020000000000
AT!BAND=10
AT!RESET

And after the reset, the modem is now registering on band 42 with the latest firmware.

I would highly recommend this page, as it contains many valuable info for the EM module type:
https://github.com/danielewood/sierra-wireless-modems


#5

@dchard,

As I have said the early versions had not restrictions,the later ones require specific bits set in the flash as we had to make sure the bands could not be used to the FCC’s position at that time.

I have messaged you privately to find which company you bought it through as if it was an official channel I need to understand why they think they cannot send it to you (they would not even be aware of it if they did not ask).

Regards

Matt