EM7565 keeps returning to QD loader mode

So yesterday I decided to try the airvantage FOTA service to upgrade the firmware on my EM7565 to save me some time, unfortunately since it went through this process I cannot get my modem to stay out of QD mode. I was originally upgrading from the gen R15 to the ATT R15, since that is the service provider I use now. I have tried several of the normal fixes, such as extracting the firmware package and using fdt2.exe to kick it out of QD mode. The flash and restart are both successful, however after the restart it will power on and off about 6 or 7 times. I watch it pop up in device manager with the normal config, but after several times it returns to QD mode and stays there. What is really odd is if I unplug the device (i have it in a usb3 to m.2 box) for my computer and plug it back it it doesn’t return immediately to QD mode, it again tries to connect several times with a normal configuration before going to QD mode. It leads me to think something in it boatloader or initial handshake sequence is corrupt. I have tried both the gen R15 and ATT R15 firmware to try and fix the issue, but it always produces the same result. I appreciate any help you can provide. I normally run it under linux, but I have done all my troubleshooting in windows 10.

Hi @penguinslovebananas

Before you use FOTA, what FW your device used? Is it GENERIC R15 and you FOTA to upgrade to ATT R15, right?

Under Windows and the FW flashed by fdt2.exe, can you share the com port about “Modems”, “Ports” in the Device Manager? Ensure that the EM7565 driver was installed on windows.


Yes it was initially on the generic R15 and I FOTA to the ATT R15. The Windows drivers are properly installed. I have double-checked and even removed them and reinstalled to be sure they were not corrupted.

In Device Manager when I initially plug in the modem, the diagnostic port and the wwan ports appear, they are com5 and com6. The modem devices will appear in Device Manager and after a few seconds they disappear. This behavior repeats several times, 6 or 7, until the QD firmware loader port, com7, appears and then it stays like that until I unplug it from the computer.

This behavior happens everytime I plug it in, even after re-installing the firmware it does the same thing.

I have also tried to fix it under linux, but the ttyUSB ports never appear. I have the Gobi drivers properly installed and they are S2.42 N2.64.

I have the modem set to usbconfig=1,3,10D, which is NMEA, diagnostic, modem, rmnet0 enabaled.

Thank you for the help.

Hi @penguinslovebananas

On windows, please help to check:

  1. Open Registry Editor, access to the path “\HKEY_LOCAL_MACHINE\SOFTWARE\Sierra Wireless Inc\DriverInstallOptionsUsed”
    Check and set the parameter FWUPDATE = OFF, AUTOFWSIMMATCH=0. And then restart the PC.
  2. Re-installing the firmware by fdt2.
    Extracting the GENERIC R15 firmware package of EM7565 and then use the command “fdt2.exe -f SWI9X50C_01.14.02.00.cwe SWI9X50C_01.14.02.00_GENERIC_002.035_000.nvu” at this path to installing FW.

Please check it and share your result.


I checked my registry and those key values are already set.
I followed your instructions for re-installing the generic r15 firmware and it produced the same results as before. No change at all.

Hi @penguinslovebananas

May a problem is inside your device before the device booted up. I think you should contact to your distributor to be checked.