EM7430 in Dell Latitude 7390 with Windows 10 - No Service

Hi, I got a dell latitude 7390 with Windows 10build 1709 and I bought from dell also a WWAN extension, Sierra EM7430
I got a Vodafone SIM. SIM is working in another laptop with similar specs but WIn7
After install the driver provided by Dell and install the Sierra Skylight I got all the time NO Service

I have removed the Drivers from Dell and Install the Genric provided by Sierra > No luck
Then I found that this link where Vodafone is not listed, but for the Skyline I can see all the Vodafone profiles created


I have the windows Firewall disabled
When Installed the Skyligt I got the Firmware updated.
I ran the netsh command but I cannot find anything that can help me

Any ideas?

netshcommandsresult.txt (3.2 KB)

EM7430 doesn’t support Vodafone image and but you can use Generic firmware image though. Please go to the following Dell website to download the driver package.

Where did you get the Vodafone SIM, from UK or in Germany? Do you know what is the right APN to be used for the SIM? From googling the web, I got different ones such as “internet”, “portalnmms”, “www”, or “web.vodafone.de” etc. You need to contact your service provider to find out the correct APN. Then adding a profile in Skylight with the correct APN is all you need to do to make it work.

Hi Tomato,
Thank you for the insight.
Yep, my first attempt was with the DELL image and then I tried with the Sierra one. With both I got the same error NO Service.

The SIM is Vodafone UK, I am checking with my provider the right APN. I will let you know soon