EM7430 in Dell E7450

Hello All,

Trying to install an EM7430 in my Dell E7450 and the device is not detected, I had a EM7305 in the same machine and it was working fine.

Anyone experienced anything like this, the device will not detect, any idea of other devices that may be conflicting with this device?



How are you doing that?? are you connecting internally?? you can confirm with your hardware team whether the connections are proper…



Have a nice day. I’m looks like the same senarios where only mc7304 and em7455 are able to install on lenovo x220/x220t running win 7 pro 64 bit and working fine, but not for mc7455 (not been recognized by the system). Based on device specification, em/mc73xx are compatible with usb 2.0 whilst em/mc74xx are compatible with usb 3.0 and backward campatible with usb 2.0. I just aware all sierra wireless mobile datacards has an intelligent errors detection where “if more than 6 consecutives reset” then that device will be at “boot and hold”, which means waiting for firmware update.

Through a google searching …no more options to move forward via sierra wireless flashing tool “fdt.exe” … then we could assume that device already “brick”.

You must likely need to tape the USB 3.0 / PCI express pins.


I’ve tried to tape pins (23 through 33) on MC7455 still doesn’t work unlike for EM7455 just tape pin #8 but working fine. I do realize when I’ve installed MC7455 into USBNS-E V1.4 (USB Converter) where only “QDLoader Port” was created inside windows’s Device Manager. “QDLoader Port” for Sierra Wireless is “Boot and Hold” which means waiting for firmware update. I couldn’t proceed further with Sierra Wireless Flash Update Tool (fdt.exe) because no other options to eliminate checking for “Modem mode”. IF no other options to move forward the I would say “USELESS” which means throw away and install with another products.


There should be no need to tape anything on an m.2 module.

As for installing any modem in a Dell PC, that’s mostly a question about what the Dell PC accepts. Which can only be answered by Dell. Given that Dell OEMed modems have unique Dell IDs,they might not accept anything else.


As general MC7455 and EM7455 should be the same “functions” except different form factor (PCIe and M.2) where shouldn’t be any pins to be taped because both are USB backward compatible. As example (my situation) where I would like to install both on Lenovo X220/X220T running Windows 7 Pro 64 bit. Yes, I’ve taped pin #8 on EM7455 (W_DISABLE_N - Wireless Disable (main RF radio), but all related devices are shown inside Device Manager. Unlike MC7455 all related devices are not shown inside Device Manager even though all related pins (#23 through #33). I do realize only “QDLoader Port” was established inside Device Manager when I’ve installed MC7455 into USBMS -E V1.4 (USB to PCIE Converter) which means that device at “boot and hold” mode (waiting for firmware to be loaded). Based on current Sierra Wireless Flash Tool (fdt.exe), we couldn’t proceed further because this tool always looking for “modem mode” which we couldn’t eliminate (refer to fdt -h). Any thought from you all how to move forward and much appreciated.