MC7455 not recognize on DELL Latitude E7240

Hello All,

I had installed MC7455 on DELL Latitude E7240 and only “QDLoader Port” was recognized inside Windows 10 Device Manager. I’ve cross checked current BIOS (A18) where it has a capability for USB 3.0. I’ve tested for MC7304 where all related devices were shown inside Device Manager where for both I’ve installed with current latest “Generic” drivers from “Sierra Source”. Yes, I aware so much information about incompatibility MC74XX on windows environment. QDloader Port is equivalent to “boot and hold” mode for that card which means waiting for “firmware flashing”. With the current Sierra “fdt.exe” tools, we couldn’t proceed further because no other option to eliminate “modem mode”. Any thought from you all how to move forward for resolution and much appreciated.


First of all, I’d suggest you to cover USB 3.0 pins (##23, 25, 31, 33) of your module’s connector with sticker tape before you insert it into your computer’s slot. Insulating all pins in range from 23 to 33 with one single piece of tape will be good too.
If this trick doesn’t help then your module is defective itself. Look at USB IDs of QDloader Port mentioned: in case of VID/PID=05C6/9008 there’s no possibility to fix a problem without a special service file called “emergency boot loader” in SWI notation.


Thanks for your comments. Actually I’ve done as instructed but the same result also and PID for QDLoader Port is (1199/9070) and believe belongs to Sierra MC7455 (based on Generic driver). If defective ? How come because I have 2 MC7455 where I’ve done all related taped from one (1) MC7455 only BUT both with the same result … stuck at “QDLoader Port” …

OK, let’s go a bit deeper and look into your laptop’s schematic diagram.
On page 31 there we can see what’s connected to your “multifunctional” (mSATA/WWAN) PCIe Mini slot and compare that pinout to MC7455 pin assignments table.
We can get possibly dangerous signal “intersections” there for pins 11,13 (PCIe clock outputs on host side vs 2 power outputs on module’s side) and pin 44 (some sleep control signal vs possibly output line).

Expand your tape mask over pins 23-33 to pins 11-13. One piece of tape for pins 11-33 seems to be good.
For pin 44, you should stick another piece of tape that will cover, say, pins 44 thru 50.

And, of course, look through your Windows environment, check for software that may work with serial ports in background, without your (user) intervention: various modem/communication managers, dashboards, software for some old mobile phones content synchronization, Huawei modem drivers, etc. Temporarily uninstall such a software, if found, to avoid possible interferention with Sierra drivers.


Have a good day and thanks a lot for your afford. I believe I should stop at this point because even though installed via USB Adapter also with the same result. Based on respective specification, the different between MC7455 and MC7304 only pins for USB 3.0 and particularly for DELL Latitude E7240 is already USB 3.0 backplane and we could disable via BIOS.

Hello All,

I would conclude Sierra Wireless MC7455 doesn’t compatible with notebook which currently configured as combo (MPCI-E and mSATA) unlike EM7455. I’ve done a testing on Lenovo Thinkpad X220/X220T running Windows 7 Pro 64 bit and DELL Latitude E7240 running Windows 10 Pro 64 bit. I’ve done testing using MC7304, MC7455 and EM7455 where no issues for MC7304 and EM7455 which means all related devices were shown inside Windows Device Manager. The only thing I’ve done only to tape pin #20 on MC7304 and pin #8 on EM7455 (Wireless Disable (main RF Radio)). As been informed, for MC7455 has to tape all four (4) pins belongs to USB 3.0 plus other pins, but still no luck and only “QDLoader Port” (boot and hold) were shown inside windows Device Manager. I had made a comparison between MC7304 and MC7455 respective “Product Technical Specification & Customer Design Guidelines” and found out on MC7304, pin #33 assigned to “system_reset_n” whilst on MC7455 pin #22 is assigned to this function. I’m questioning why no issues on EM7455 but so much issues on MC7455 ? By right shouldn’t be too much different because both sharing the same VID/PID (1199/9070). Based on these all I believe MC7455 should be backed to factory and redesign again all pin functions in order to be installed on latest notebook with a “multifuctional” (mSATA/WWAN).

The MC7455 works well with a Dell e7240 (touchscreen FHD) with no pin taped. I have successfully tested this module in various laptops (Dell XT3, Fujitsu T731/T580/P8020), but one problem persists across all platforms: the gps-sensor stops working after 10-15min although the NMEA-port continues to provide data (readable with Visualgpsview).
To your problem: the active QDLoader Port can be a indicator of an unsuccessful firmware upgrade. You can try to upgrade the firmware again.

Other useful experiences: You can convert the Dell DW5811e and the Lenovo-branded EM7455 in free, original Sierra Wireless EM7455 in order to use them in other laptops, and this process is reversible!

Hello baodo,

Have a good day and thanks a lot. Maybe no luck for me where both of my MC7455 cards are with the same result “QDLoader Port” (boot and hold mode). Yes by right shouldn’t be any pins to be taped as compared to the same sibling EM7455, but I’ve tried so many times firmware update via Sierra Wireless Firmware Loader Tools (fdt.exe) and the result still same. Actually “fdt.exe” does checking “modem status” which doesn’t exists and couldn’t be eliminated. Anyway, may I know which OS releases where you have success full install MC7455 on DELL E7240 ? I believe your E7240 does inherit the same Mini WWAN schematic diagram.


I’m using WIn10 64bit pro with all the recent updates.
Have you tried to install this new firmware package? … d-,017_000

Hello Mr. Baodo,

YES, my E7240 also Win 10 Pro 64 bit but not yet with recent updates. I’ll try later to update mine with all recent windows updates. About the recent firmware, YES I’ve successful done for my EM7455 but not yet for MC7455. Anyway thanks a lot for your valuable information.

IMHO I don’t think your problem has anything to do with any version of WIN 10 Pro. I should install the firmware xxx.exe if I were you. If I recall correctly, I have installed some older SW modules after seeing the QDloader-Port, just in order to free the card from download mode. There’s no risk to brick your MC7455 in doing so under Windows. I should give this method a try.

Hi Mr. Baodo,

Still no luck with that latest firmware because that “fdt.exe” still looking for “modem mode” which doesn’t exists except “QDLoader Mode” (boot and hole) and couldn’t be eliminated. YES, if you could provide all steps and much appreciated.


Please try this: Remove all the drivers (Programs And Features) without remainder (i.e. removing all Sierra Wireless folders). Remove the module and tape out pin 20, this pin only and then reinstall it and let us know what appears in “other devices” in Device Manager.
My old MC7710 refuses to work in every single Dell laptop until I taped pin 20. It worked then flawlessly.


Thanks a lot. YES that pin #20 acts as "Hardware Disable for Wireless Signal) where actually I’ve done as mentioned but still the same. Today something had happened where only Network Adapter exists in Device Manager (EM7455) after Install latest “Generic” drivers from sierra source as well as flashing with latest firmware release, but still could access internet and very weird for me. Any thought from your end.

Hello Mr. baodo,

I would like to know system has intelligent enough to detect any device such as MC7455 which currently designed for US and Europe regions couldn’t be used in APAC Region ? Because I’m from APAC Region and believe EM7455 is designed to be used in APAC Region as well. Why I’m asking this “funny” question because currently I have two (2) MC7455 where both with the same result where only showing “QDLoader Port” (bootloader mode) inside windows Device Manager and based on your findings also no need to tape any pins on MC7455 to be installed on DELL Latitude E7240. I believe you’re from US or Europe Region ?

I’m indeed from Europe. If this is the case as you mentioned above, you can try to outwit the system by changing time, language & region to US or UK.

Hello Mr. Baodo,

Have a good day. I believe the real problem is not related to region or something else but related to “Parent” and “Siblings” parameter for each MC7455 devices within Windows Device Manager. I’ve cross-checked my MC7455 “QDLoader Port” for “Parent” and “Siblings” are different with “Hardware ID” where 'Hardware ID" is “USB\VID_1199&PID_9070” whilst for “Parent” and “Siblings” taken from Lenovo X220T is “USB\VID_8087&PID_0024” and “USB\VID_056A&PID_00E6”. I’ve made a comparison with “working” EM7455 where both parameters are “USB\VID_1199&PID_9071”. I believe that why both of my MC7455 are booted at “bootloader mode” because hardware ID and Parent/Siblings ID are not same. Could you check from your end for that working MC7455 and believe my findings are correct. Any thought from your end for resolution and much appreciated.


I don’t think the problems of your MC-Cards have anything to do with these IDs (in case you didn’t change them with AT-Commands). You can try to use a Mini PCI-E to USB Adapter (with SIM card Slot for WWAN/LTE Module) and hence bypass possible restrictions of the internal miniPCIe-Port. Please do that and post the results. I’m really curious because I have absolutely no problems with this card in combination with diverse old laptops (Fujitsu P8020, T580, T731 and Dell XT3).
Good luck

Hi Mr. baodo,

Have a good day. I’ve done as adviced via PCI-E to USB (with SIM Slot), but still no luck where only could see "QDLoader Port " (boot and hold) inside Windows Device Manager (refer to attach). I have MC7304, MC7455 (2 units) and EM7455 where all bought from Mainland China where only MC7455 got problem where both with the same result (boot and hold) status. Besides DELL Latitude E7240, I have tested on Lenovo X220/X220T and HP Folio 9470m where for these cards (MC7455) with the same result (boot and hold) and I believe (might be) the problem with that card itself. The same PCI-E to USB, I have tested for MC7304 and EM7455 without any issues. I don’t have any idea how to resolve these issues via Sierra Wireless Firmware Loader Tools (fdt.exe) because we couldn’t eliminate checking for “modem status” then couldn’t proceed further. May I know where do you buy that MC7455 card ? I heard lot of related data cards from mainland china are in “testing status” and would like to know am I right ?