How to use MC7455 on Linux?

i have a Linux laptop and i cant get it to recognize my MC7455 at all. i am trying to upgrade from the 7355 as it doesnt support LTE. the 7355 worked perfectly on this same Linux setup, but the new 7455 wont show up at all under lspci or lsusb.

has anybody gotten the MC7455 to work under Linux? if so, how?

Hi Matthew,

You can find the drivers and SDK under
But your problem is not driver related.
Even without the driver installed, lsusb should list the modem.
If the modem doesn’t show up in lsusb then the device is not even enumerating on the USB bus.
It has to be some HW issue.

How do you connect the modem to the PC? with an external devkit or do you have an embedded slot?

my laptop has a dedicated mini PCIe slot for wwan modems. this is how i am connecting the device to the PC.
i dont believe the slot on my laptop is malfunctioning, as the Sierra Wireless MC7355 worked flawlessly with my current configuration, the only change i have done to the system was upgrade to the 7455.

so then. the real question is: How do i get the 7455 to enumerate on Linux?

This is most likely a platform issue and therefore completely independent of both Linux and the 7455. The modem will enumerate in some way if it is powered and connected to the USB bus. You should check that.

Depending on the configuration of the modem, you may also have to make sure pin #20 is high or not connected.

The MC7455 USB3 SS support can also cause problems in laptop slots with PCIe. You should disable PCIe in the slot and/or modem, or simply cover the pins with tape. See e.g for instructions.

And finally: Many laptop vendors will whitelist supported wifi and wwan modules. Using a different modem will result in a POST error. But YMMV. Maybe your laptop disables the slot instead.

that tutorials says this can be solved with AT commands. but i am confused how one can issue AT commands to a device that doesnt enumerate.
if i can get this modem to work without having to block any pins that would be best.

Yes, there is a bit of a chicken and egg problem here. This is only an option if you can connect the modem to a host without the issue, using a USB only adapter or slot. Or you can temporarily cover the pins until you have configured the modem. But covering the pins can also be a permanent solution. This used to be the only alternative before the firmware got support for disabling USB3

does there exist an external device i can use to configure the modem using my laptop’s USB3-A ports? i wouldn’t need antenna functionality on such a device, only the ability to use the AT commands in order to make the modem function in my laptop’s built-in wwan slot.
if so, can you recommend a model?

There are lots of adapters like this on aliexpress and ebay:

Search for “usb lte adapter” or similar. I have not tested that particular adapter or seller, so this is not a specific recommendation. Just a random hit on my search.

I don’t know if USB3 adapters for mini-pcie exists. But you don’t need USB3 for this purpose, so it would be a waste of money anyway. Just go for one of the USB2 adapters. The modem has no problem falling back to USB2 as long as there is nothing connected to the USB3 pins, and there won’t be with an adapter like this.

would this work?