MC7455 Not Detected - Ubuntu18.04


#1

Hi,

I have had an MC7455 module for a couple of weeks with no luck at all getting it even recognized on Multiple Ubuntu/Debian machines. I plug the module in a mini-pci port but it doesn’t even show up at all on the machines I tested it up with with Intel/AMD platforms. If I swap out MC7455 with a mini-pci wifi module I see it with no issues. In both cases I check with lspci. With the Wifi module I can see the pci bus address and the device name as expected. When I plug the MC7455 in the same exact port I don’t see anything. Again, I have seen the same behavior across multiple machines. And they all acted as if the MC7455 doesn’t exist. One of the machines becomes really slow if MC7455 is plugged in but I still don’t see it appear in the system.

Do I happen to have a bad chip or I’m I missing something ?

I appreciate any help and thank you in advance.


#2

That won’t work. The MC7455 is a USB device.


#3

I tried lsusb as well, but I didn’t see any new device with MC7455 plugged in.


#4

You might want to study the MC7455 pinout in the PTS and compare it with the pinout of your mini-PCIe slots. They are likely incompatible if you are using standard laptop slots. This can easily be fixed by masking off a few of the PCIe pins with a piece of tape. Google it.


#5

dl5162,

Thank you very much for your help. I was just reading about pinout in other posts and the “taping” trick. I think that is my issue here. Are you aware of any adapters/risers that masks those pins to avoid taping the module? I have seen pci-e to usb adapters with sim slots as well, but I was wondering if there is something I can plugin to one of my pci slots directly. I’m testing this on a desktop.

Thanks again.


#6

dl5162,

I also tested the module on this system:

https://www.kontron.com/products/boards-and-standard-form-factors/motherboards/mini-itx/mitx-e38.html

The board has a SIM slot and the mini-PCIe explicitly listed as supporting 3G/4G over USB2.0.

The system boots really slow when the MC7455 module is plugged in, but I still don’t see it detected anywhere.

Thank you again for the help.


#7

The mini-PCIe pinout depends on the application. A slot supporting both wifi and 3G/4G will have 1xSIM, USB2 and PCIEx1. Most 3G/4G modems have 1xSIM and USB2. The MC7455 has 2xSIM, USB2 and USB3. These variants are all allowed by the PCI-SIG specs. But there aren’t enough pins on the connector for every combination, so some of the pins are shared. USB3 and the second SIM will conflict with PCIEx1. This can cause issues like those you describe unless you mask the conflicting pins.

The MC7455 works fine without USB3 and the second SIM, so this slot incompatility is not a problem as long as you tape over those pins. The fix is simple. Just do it


#8

dl5162,

I went with your advice and used nail polish to cover pins 7,11, 13, 23,25,31,33. I will report back once this thing dries and I get a chance to test.

Thank you very much again.


#9

dl5162,

No luck yet after taping those pins, here is the connector specs of the board I have, any suggestion?


#10

Sorry, I’m out of suggestions now. Your slot pinout looks fine, and covering pins s 7,11, 13, 23,25,31,33 on the MC7455 should have been enough.

The only odd thing I noted about the pinout is pins 17 and 19. They are claimed to be NC and used by the SIM interface. Which doesn’t really make any sense. These pins are normally reserved for SIM, but rarely connected to anything. They are however part of the second SIM interface on the MC7455.

Can’t imagine that this should cause any problems though. It’s most likely just an error in the pinout diagram, to be interpreted as “NC”.

Note that you can probably get away with covering all the odd pins (i.e. all pins on the component side) on the MC7455 if you don’t need any of the WAKE_HOST, GPIO, SIM2, USB3 or AUDIO signals. Which is often the case. At least for laptop/generic board usage.


#11

dl5162,

Given your assessment, I deiced to try again. Before going home for the weekend I redid the taping including pins 27 and 29 to make sure the whole strip of pins 23-33 is all covered really well. I left it to dry over the weekend. This morning I plugged it in and it worked!

Thanks a ton! I really appreciate your help to get it to work. Now off to the next task! making sure the drivers work and the module functions as it supposed to.


#12

Just to update this port, after my last change, everything else worked smoothly including the open source drivers on Ubuntu 18.04.

Thanks again dl5162!