EM7345 issue with Connected standby (firmware issue)


I have Lenovo tablet with Windows 8.1 x64 and EM7345. The issue is that when mobile connection is connected, going to connected standby (sleep) mode, after few hours resume from connected standby, the EM7345 device sometimes disappears from Device Manager and new unknown device ‘1 CDC’ appears instead. It is hard to reproduce it but I have used a Microsoft logging tool and have 7 MB ETL log of such session. Could you please help me how to diagnose it and possibly find a solution ?

It is reported and confirmed by more users for Lenovo ThinkPad 8, ThinkPad 10 and Yoga Tablet 2 tablets. It is also possible the issue is mobile provider specific.

Thanks for any help.

Long version:

You can find more details here http://forums.lenovo.com/t5/ThinkPad-Tablets/Sierra-Wireless-EM7345-ThinkPad-8-and-10-general-issues/td-p/1839763 including some diagnostic output and steps how to reproduce it by WWAN Logging Tool. When the issue occurs, the USB composite device, EM7345 network device and GNSS device disappears. There is new unknown device ‘1 CDC’ in Device Manager instead with different VID/PID (1519/F000 = Comneon GmbH Co). Generic Microsoft driver is used for EM7345 network device (MBIM device).

I have used Microsoft USB3HWVerifierAnalyzer to create ETL log for the issue but I am not sure there is anything useful. It is 7 MB ETL file. You can see brief error output in 3rd message of the Lenovo forum post. There are several reports of Device Control Transfer Error and Client Initiated Recovery Action event messages.

I have already tried to reinstall the driver package (provided by Lenovo), disable Selective suspend in driver options, disable D3cold in registry, update BIOS … no improvement. There is Sierra Wireless MSI software installer provided by Lenovo but it does not install Sierra Wireless EM7345 network device driver on Windows 8.1. It rely on Microsoft MBIM driver but there are Sierra Wireless driver files inside the MSI package. By looking to the MSI condition table via Windows SDK Orca Editor it seems the Sierra Wireless driver is installed on Windows 7 only. Would be possible to use the Sierra Wireless EM7345 network device driver on Windows 8.1 instead of the Microsoft one ?

My current workaround is to remove the phantom ‘1 CDC’ device from Device Manager and perform ‘Scan for hardware changes’, using such procedure the EM7345 composite device appears again without a need of machine restart. I have automated it using devcon.exe Windows Driver Kit tool but it is just an ugly hack, moreover the resurrection takes up to 30 seconds so it is not convenient.

I have also found discussion EM7345 probing fails when coming back from suspend but I am not sure whether it might be similar issue (on different OS).

Could you please contact your Lenovo distributer/reseller for more information. There are multiple release for the Lenovo drivers which will help you to resolve the issue.


Lenovo is no help in such cases unfortunately. They are able to “try to” replace the EM7345 device without any further diagnostics only (with the same result again). Moreover it takes one month to get the replacement part.

Now I am testing whether there is an improvement after EM7345 firmware update from FIH7160_V1.1_MODEM_01.1349.12 to FIH7160_V1.2_WW_01.1415.07 version. The firmware update is included in Lenovo software package intended for ThinkPad 10 tablet model but there is no such firmware update avaiable in software package intended for my older ThinkPad 8 tablet. Again, this is typical for Lenovo that they are not updating software packages for older (but still supported and available) models that you have to use software for different (newer) model. It had been that way in the past with WWAN devices of other vendors too.

Could you please be more specific about the “Lenovo drivers which will help you to resolve the issue” ? My understanding is that for Windows 8.1 there is no Sierra Wireless EM7345 network driver because the device always works in MBIM mode thus uses Microsoft generic driver.

My intention was that I hoped you can recommend me some of your development/diagnostic tools that can diagnose the issue.

The firmware update resolved some issues but some others still remains.

Is there any way to download new firmware files directly from Sierra Wireless ? Including list of fixes. Lenovo is very slow with releasing them.

We’re having the same sort of issues with 100+ new Lenovo Helix Generation 2 (20CH) machines. Using latest driver from Lenovo and firmware version is FIH7160_V1.2_WW_01.1442.04_VZ

There is Microsoft hotfix KB3036606 Windows 8.1 mobile broadband may not auto-reconnect after it resumes from connected standby released on March 11, 2015 that makes an improvement. I still experience issues when signal is lost in train tunnel etc, the EM7345 is not able to reconnect unless OS restart (driver restart does not help).

Installed that hotfix. No improvement.

I see. What is the exact issue ? Randomly disappaearing EM7345 device in Device Manager or stuck/dropped connection that can not be reconnected again without OS restart ?


Sad. Unfortunately I don’t see any solution because the issue is known for almost one year without any official response. Sierra Wireless is routing the issue to Lenovo, Lenovo does not care either :frowning: You can go through the Lenovo forum where you can find links to russian forums describing some hacks using a chinese firmware for EM7345. You can get mixed results including dead module of course by applying it. On the other hand there is at least someone trying to resolve it :imp:

This site zukota.com/sierra-wireless-em734 … -firmware/

Is there any official list of firmware versions with changelog ?

New version of Lenovo EM7345 software package 2.1.10640.4269 has been released today
support.lenovo.com/us/en/product … s/DS101007

It contains updated firmware.

Just a warning. I have tried the new 1442.07 firmware in ThinkPad 8 tablet and it was a disaster :frowning: I had to revert back to 1415.07 version. I don’t understand that the company (Infineon ?) is not able to produce stable firmware. Any QA out there ?