EM 7511 Reset Utility

I need to reset the EM7511 cellular module. On older devices there was an ieOC.exe that would reset the module, but I cannot find something similar to perform the reset. Is there some sort of utility that will do this?

Everything shows up normal in the device manager with no errors. It lists Sierra Wireless in:
Modems (not disabled, no exclamations, warnings, etc)
Network Adapters (not disabled, no exclamations, warnings, etc)
Ports (not disabled, no exclamations, warnings, etc)
USB > Composite Device (not disabled, no exclamations, warnings, etc)

However the cellular will not work. I have swapped drives with an identical device (exact same hardware) and it works on the other one with this hard drive, so I know it is not a software issue. I also made sure the BIOS shows WWAN is enabled. Windows just doesn’t seem to be able to find it. In a last ditch effort, I reinstalled Windows fresh, but the same issue persists. I have also tried uninstalling and reinstalling the Drivers and Firmware to no avail. Windows just will not see the cellular module. In adapter settings (Control Panel\All Control Panel Items\Network Connections), it shows it disabled, but when I try to enable it, it will not enable.

Really hoping I can get it to work by resetting it. It seems to have stopped working when I installed a Virtual GPS software to split NMEA data, but instead, it seems to have broken the cellular module to an extent.

  • Update:
    Using Windows 10 21H1
    Carrier is Verizon

How about sending at!reset in modem port?

Pretend I don’t know how to do this. Can you provide instructions or a link to some instructions?

Download tera term and open the modem port to send AT command

Do you have a link to this tera term?

Can you search it in google

@jyijyi So I downloaded tera term and pointed it to the serial com port, but how do I send the “at!reset” command?

  • Obviously I’m new to this and don’t want to mess something up further.
    Do I go to Control > Broadcast Command then type at!reset into the field and click Submit? If so, what should I expect to happen in there after I submit? Should the port go away and how does this affect the rest of the module since it has listings in other places, namely:
  • Modems
  • Network Adapters
  • USB > Composite Device

Note that what I really need working is the Network Adapter. Just making sure that is understood.

Just type at!reset in the tera term and it will return OK

Thanks for your help, but I think I need clarification. I’m not sure how to get it to allow me to enter text unless I go to Control > Broadcast Command. When I run tera term, it opens and asks what protocol and I set COM and select the COM with the Sierra Wireless listing, but it doesn’t let you just type anything right there.

Maybe you choose the wrong port for modem port?