Disabling WIND notification


#1

Modem : Q2686RD
Firmware : 7.44

I’m trying to disable +WIND notification from my Open AT Application.
As far as I know, I can’t do this through the API, so I’m calling

adl_atCmdCreate (“AT+WIND=0”, FALSE, MyHandler, “*”, NULL);

The callback is called and I receive “OK”
But, I’m perplexed, because this statment as no effect !
(I check with AT+WIND?)

If I call AT+WIND=0 the notifications are properly disabled.

Any one can tell me why, and how I could disable these notifications from my application ?

Thanks.


#2

If I still don’t know how to fix my issue, I have an explanation :

In ADL User guide. §2.2.1 :
ADL is internally using +WIND indications in order to be kept informed of events raised by the embedded module. It has its own +WIND configuration […]

The point is that I wish to set from my application the settings for the “outside of my application”…


#3

And it is all you can do. You can send “AT+WIND=0” from external application after application downloaded and started. Custom downloader with script capability do all download-run-setup for me at once.


#4

The are two settings of the “WIND” messages depending on state of OAT application ( running or not). You should not modify the WIND settings when the OAT applicatin is running!

Simply subscribe to all the WIND notification wiht “adl_atUnSoSubscribe” function and do not return it to the external application.


#5

As usual, you can do all you want if you know what you do. Open-AT application by default set WIND indication as 32763, so your application will never receive “AT-engine ready” (+WIND: 3) without SIM-card. Strange policy, if you want to know my opinion and must be corrected in future. So my applications usually anable full WIND indication (AT+WIND=32767) internally without any negative effects.