Developer Studio for ALEOS cannot connect to gateway "Algorithm negotiation fail"

I am unable to connect Developer Studio to the MP70 plugged in to my computer via USB.

In Remote System Explorer I right click on the defined connection for and hit ‘connect’. I then get a dialogue box with the message ‘Failed to connect sshd on “”’ . Clicking through to details tells me ‘Algorithm negotiation fail’.

I have the AAF user enabled and have made sure passwords match between the device and Developer Studio.

I have connected successfully in the past, but I have since updated the ALEOS version on the MP70. Either the current version of ALEOS is behaving differently or I have forgotten how to get the connection up and running. Any help or advice would be much appreciated.

The MP70 is running ALEOS Version 4.15.3
Developer Studio is Version :

Hi AP11,

For USB, please try to connect with IP


I tried both and using USB and ethernet and got the same error.

I have now rolled back to ALEOS 4.14 and the software connects properly.