Dev. Stududio 2.3.1 problems with old Q24pl projects


#1

Since developer studio upgraded to 2.3.1, old q24 projects have started to have problems with libraries references, specially “adl_global.h” library. I loaded it manually (ADL/itf; ADL/hidden; ADL/basic) at project properties(Build and General TABS) and eclipse recognized it but there were still functions unrecognized and lots of build errors.

I decided to downgrade my dev studio to 2.3.0 version and Q24 projects are working without problems again.


#2

Hi,

Can you try once by importing the project to new Workspace rather than manually loading it?
Thanks


#3

Hi,

I tried different things and I think I imported and created new projects but it was not possible to solve it.

Anyway I will try it again in other computer where I have a 2.3.1 DevStudio. I will post the result

Thanks


#4

Hi Luis,

I experienced exact the same trouble when migrating to 2.3.1. To solve this problem, I created an entire new workspace, created new project(s) en copied the source files from the original workspace. This seems to do the trick, but it isn’t quite user friendly.

Hope this helps

Regards,
Kris


#5

Hi Signum,

I have followed your steps but it does not work for me. I have created a new workspace.
But when I create a new Project with 2.3.1, ADL libraries are not included. If I import the Project, this libraries are also missed.
Then If I manually include them, there are tons of build errors
I have also created a sample Project following the steps of the wizard and same problems.

The package I include for working with Q24 is “Open AT SDK packege (3.22.0.RC1)”. This was the last released package.

Thanks


#6

Hi,

just made the test with DS 2.3.1 & the Open AT SDK 3.22, and a simple HelloWorld project builds successfully.
Please can you attach a DS technical report here? (Help > Build Technical report, add your project, and export the ZIP file)

Thanks


#7

Hi,

I have tried to make HelloWorld project with the wizard and builds successfully for me too. But this project does not need ADL references.
Then I have made TCPCLIENT sample project that includes WIP libraries and needs ADL references and this project have the problems.

I attach the report of TCPCLIENT project you ask me.

Thanks


#8

Ok, we got it.
There is an incompatibility with DS 2.3.1 and Open AT SDK 3.X versions.
This is due to the fact that these SDKs were providing both ADL and legacy “basic” APIs.
To workaround the issue, it is possible to disable the “basic” API in the Open AT OS package:

  • Go to the Package Manager
  • Select the Open AT OS 3.X version used by your project
  • In the right-click menu, select “Explore Package Resources”
  • In the opened explorer, select and open the “package.xmi” file in a text editor (maybe do a backup copy of this file before editing it)
  • You’ll find two “implementedAPI” tags in this file, one with the “BASIC” ID, another with the “ADL” ID. The workaround is to delete the “BASIC” one (with all its children, obviously) to keep only the “ADL” one.
  • Restart DS
  • In your project, go to properties > Open AT Application, and just click the “Apply” button to compute the update.

From there, the project will build correctly (include paths will be updated to the ADL ones)


#9

Hi daav,

As soon as I can I will check the workaround. I will post the results
Thanks a lot… :smiley: :wink:


#10

hi,

I have just checked the workaround. It works perfectly

Thanks.