Studio fails to find stdlib etc


#1

Im currently attempting to import a bunch of source files into the studio, in order to test/compile/execute them in the studio. However the source code makes use of stdlib, stdbool etc which the program fails to find, labelling them as unrecognizable. I thought these are std files that are part of the c environment present in the studio? please assist in making these visible to the IDE


#2

These are “overridden” by the files included by adl_global.h


#3

adl_global is also included and frequently used in the source files, so is there any way to make these stdlib, stdbool files visible? without removing adl_global.


#4

i dont know if this helps but, even the adl_global file is labelled as unresloved inclusion! how can that be? i downloaded the complete set of files neccessary for the device im using.and updated to latest lib versions aswell…


#5

So you have a fundamental problem with your project!

Did you create it as an Open-AT project?


#6

im sorry if it seems im wasting your time: i indeed had tried to import the files under an Open At project, having failed i tried a simple helloworld type of example, again ofcourse as an Open At proj. Build worked fine but when i try run the project, it gives an error warning saying no binary file found?? surely a binary file is not neccessary just to test something. from my knowledge, a binary file could be an end product, something that would be transferred onto a device once the project has been written in the studio?


#7

The “binary” file is what you run.


#8

alright, that clears the confusion. but why on earth is it then not automatically generated by the builder. how is there anything that i could have influenced to mess up its creation/execution, as the project is pretty much custom generated by the studio itself??