Adl_global does not include error (new to dev studio)

Hi there,

I am taking over from a former colleague on a project and I am having some troubles building his previous projects on my computer.

just FYI, I am working on a SL6087 AirPrime sierra wireless GSM module

as per his instructions I downloaded the correct framework package in properties>Open AT Application>package import wizard>Open AT Application Framework Package (
he said that I need to make sure I have the internet library installed, so I downloaded it with the framework.

once downloaded, I selected the correct profile (Open AT Application Framework package (
this automatically selected the following:
OS: Open AT OS package (
Firmware: Firmware Package (
and on the libraries tab, I ticked the “internet library package”

once all was selected, I tried to build his project but I still get the errors:
include error: adl_global.h: no such file in directory
and a few package missing errors. I attached an image of my errors.

I tried cleaning the project for a fresh build but it did not make a difference.

could someone please point me in the right direction? I dont have a lot of experience on eclipse based IDEs



Please follow the following steps.

  1. Right click on the project.

  2. select properties.

3.Go to C/C++ General -> Paths and Symbols.

4.Verify the library files included (order should be same as order in the attached screenshot).

Please make sure that the libraries included are same as given in screenshot and then test your application.