CNMI always reset to +CNMI:2,0,0,0,0 automatically


#1

Hi,
I’m using a Wavecom WMOD2 modem for sending SMS. I found something strange.

I use AT+CNMI=2,1,0,1 to get new SMS and delivery report indication. But after I get first +CDS: indication, the CNMI value change to +CNMI: 2,0,0,0,0(default value) automatically.
I even tried to set AT+CNMI=2,1,0,1 before I send each SMS and set it again every 15 seconds. I still cannot get all +CDS indication.

These are the commands sequence I’s using.
AT&F
ATE1
AT+CMGF=0

AT+CNMI=2,1,0,1
OK

AT+CNMI?
+CNMI: 2,1,0,1,0 <—this is the value I set, it’s correct.

AT+CMGS=…

+CMTI: …
+CDS: …

AT+CNMI?
+CNMI:2,0,0,0,0 <—Check it after +CDS: indication, the +CNMI value just changed to the default value automatically. :question:

I’m using USB2COM adapter to connect to this modem on my laptop. Could anyone tell me why it happens? How can I fix it? Thank you very much.


#2

Read the AT Command descriptions carefully - I seem to remember that it’s all rather complicated, and some settings are supposed to reset others at certain times… :confused:

See: viewtopic.php?f=53&t=2151&p=7936&hilit=cnmi#p7936

and: viewtopic.php?f=21&t=1509&p=5541&hilit=cnmi#p5541


#3

Thank you awneil. :slight_smile:

I have fixed this problem by using GSM 07.05 Phase 2 version 4.7.0 instead of GSM 07.05 Phase 2+ version. :smiley: