Can't put devkit in developpement mode


We just received a devkit with the FXT009.
When we try to open the port in Developpement Mode using Developper Studio 2.3.2, we get an error saying “The target is responsive, but seems to be active in Dev Mode on another port”.

When we agree to force the Dev Mode on this port, the AT+WDM=1 command fails, and we get the following error in details :
Enable persistent development mode => ERROR: Persistence command not supported on the running FW

The only info that we can get is the Serial Number. Firmware upgrade and DWL upload aren’t possible.

How can we fix this?



Are you connecting to the FXT009 via serial or USB?

Try connecting to the modem via the serial port (you can use a USB-Serial converter to do this - I use converters bassed on the FTDI chipset because I haven’t had any issues with them over the years). You will need to make an adapter cable to go from the HD15 on the modem to a DE9 to fit into your converter.

For some firmware versions of the FTX009, the USB is NOT enabled by default, and has to be enabled via the serial port using the command


and then reboot the module using


Hope this helps somewhat.

ciao, Dave

Please can you try to open the connection in production mode, and enter the ATI9 command in order to check which FW version is running on the device?


Thanks for your answers.

I tried both USB and Serial, none worked.

ATI9 command gave me :
“DWL”,“V08b0j”,"",“Wavecom”,54744,“022410 18:01”,“e9be6255”,“00010000”
“FW”,“FW_SRC_743_6_F3_1.Q2687RDG”,“R7.43.3.201201300737.FXT009”,“Wavecom”,2141296,“013012 07:37”,“daa98365”,“00020000”
“OAT”,"","","",175504,“040110 06:26”,“cbd05ab1”,“00260000”

I also tried to update Developper Studio from 2.3.2 to 3.0.0, with no luck.


Please don’t upgrade to DS 3.0: it is only compatible with FW 7.5X
To be able to deal with FW that don’t support Development Mode persistence (like 7.43), please go to the Window > Preferences > Developer Studio > Target Management, and uncheck the options that enable the Development Mode persistence.


I couldn’t try you solution until now.
It did the trick, and I can open the port in devellopement mode, thanks a lot.

I have a problem with the firmware upgrade, but I’ll open a new thread as it is a completely different issue.