Botched firmware upgrade causes device safety mode TEMP


#1

Em7455 vid 413c pid 81b6

Didn’t realize that it was possible to have generic firmware on a branded em7455, so I think I really screwed up, twice!!! First I put my em card into a usb adapter with sim card slot on windows 10 and it automatically worked via (I think) QMI mode with stock win drivers. So I connected to my provider, surfed, and then headed over to the drivers page to install the newest generic firmware(https://source.sierrawireless.com/resources/airprime/minicard/74xx/fw9999999_9904609_swi9x30c_02,-d-,24,-d-,05,-d-,06_00_generic_002,-d-,026_000/). However it failed due to the fact that certain ports weren’t open due to missing drivers:

here’s what the output looked like

awaiting adaptor…
setting image preferences…
reseting…
awaiting download port…
enabling selective suspend…
firmware download failed.

primary error code 82:
secondary error code 5:
device error code 0x0:

then it went on to tell me that the old firmware version was 001.003._000
and the old build id 01.02.00.02_GENU-4G but that nothing was flashed, so the new firmware and build version were blank, so hit enter to exit.


After that the led on my usb to m.2 adapter failed to ever light up again and windows said that the modem was turned off, and that there was no way of turning it back on? So I grabbed skylight and it said “device safety mode TEMP”. So I messed with the instillation of “AirPrime EM_MC Series Windows Drivers QMI build 4743” and with the right command line options I got all my com ports and such to show up in windows device manager. Unfortunately they all have explanation points with the error code(10) device failed to start.

I guess messing up one card wasn’t proof enough for me, so I pulled out another em7455 with the same vid and pid, but with a little older generic firmware already installed, and tried to flash it to the newest generic firmware and kaboom. The same problem, the flash failed and now the card fails to start due to device safety mode TEMP"

Any help would be appreciated.


#2

Hello,

I believe that you branded EM7455 is for DELL notebook models (based on VID and PID). I believe you should look for below website (at least got some idea).

https://zukota.com/sierra-wireless-em7455-how-to-enable-com-ports/

Regards,