EM7421 firmware

I think I bricked it!
Trying to get the card working I ran the wrong firmware update, now the card is missing completly.
I’ve tried running what I think is the correct firmware too but to no avail.

Where can I find the original Firmware, and how do I force in in?

Hi @tim.strange,

Welcome to our community!

You can refer to the following link to determine the firmware for EM7421:


Thank You @jerdung

it would seem there are more drivers than I need there, which I did not initially expect and accidently installed the driver for EM/MC7411 Now when I have found the correct drive, but the installer cannot locate the hardware.

Have I bricked it? or is there some way to revive it?

Hi @tim.strange,

What driver are you currently using? Please download and install the driver from the source page at the following link: https://source.sierrawireless.com/resources/airprime/software/airprime-em_mc-series-windows-drivers-qmi-build-latest-release/#sthash.scXdSpba.dpbs
After installing the driver, is there any port displayed on Device Manager? Please share a screenshot with me.


Apologies, my previous message I talked about drivers, when I meant firmware.
I left the PC off for the weekend and on return I found the modem was active.