AT command for MC8305 Disable Antenne Diversity

Hi ,

Does any know how to enable/disable Antenna Divertisy,
I search for AT command interface guide, no RXDEN but only AT+WHCNF, type 5, mode 0~2

mode 0 - deactivate the diversity antenna test (default value)
Tx RF path uses the main antenna path; Rx RF path uses the main path and
the diversity path if the diversity antenna is connected
mode 1 - activate the diversity antenna test
Tx RF path remains to the main antenna; Rx RF path uses only the diversity antenna path
mode 2- get the diversity antenna test status .

Does it means RX diversity is disabled if no antenna connected to RX path?
If not, how to disable it by AT command or something?


I got the 2 AT command specs from FAE, there is no aux rx (diversity) related command inside? AT_Command_Interface_Guide_7.47.pdf and 80-VG756-1_AT_COMMAND_SET_GOBI.pdf and AT_command_set_in_gobi.pdf
What I should request or there is no such command in Mc8305 gobi or MC8305 can’t disable AUX RF?

Best Regards,

If you’re in communication with an FAE, have you actually asked him/her this question :question:


I think the FAE doesn’t know how to do it, so I only got those AT command spec,
But I can’t find TX/RX path or AUX RF enable/disable related commands,
In another AT command guide, we can easy found the commands, like !DIVERSITY or !RXDEN, not can’t found them in Gobi 3000.
Maybe Gobi 3000 can’t disable RX divertisy ( no such AT command ), or I need another document, hope anyone can point it out.

Best Regards

Why do you want to disable diversity?


Sorry, it’s because only one antenna in our design.
Even if I know the AT command, another issue is, Could the additional AT command be added into Watcher?

Best Regards,