APTX License and/or Melody upgrade

Hi,
I want to use the APTX on my BC127 module. When I request the license information from it, it shows that I don’t have one, which is true, but where can I get one?

Also, I think I’m in need of a firmware update. When I enter VERSION, I get this

BlueCreation Copyright 2013
Melody Audio V5.0 RC11
Build: 20131106_115156
Bluetooth address 20FABB08F675
Profiles: SPP HFP A2DP AVRCP PBAP MAP BLE
A2DP Codecs: SBC

Is it possible to upgrade the version from 5.0? How can I go about doing this?

Hi @biomurph1

Yes, it is. Please upgrade it to the latest BC127 firmware.
You can use DFU tool to upgrade BC127 firmware.

You can get it here BC127 Firmware Upgrade Tool
BC127 Firmware

Please help to tick “Solution” if your question is answered.

Thanks Donald!
I have to dig up a Windows machine and dust it off.

Perhaps then the APTX will ‘just work’ ?

Hi biomurph1

Yes, it is.

Sierra Wireless Copyright 2018
Melody Audio V7.3
Build: 1544637564
Ready
CHARGER_DISABLED

LICENSE
APTX=ABCD 1234 0000 FFFF 0005
CVC=CDEF 5678 0000 BBBB 0002
OK

Please help to tick “Solution” if your question is answered.

1 Like

Hi,

tldr: Melody Upgrade Tool failed multiple ways

I did download the BC127 Firmware Upgrade Tool and versions of the BC127 Firmware from the pages that you linked to. I am not getting the new firmware to download onto the BC127. I’m hoping this is an issue is something that can be identified. Here’s my process and result, with notes about the hardware and my OS.

Using Windows 10 (spent the time to do all the Windows Updates)
Downloaded the Melody Updater 5
Installed the dependancies
Connected to my BC127 via UART <> USB_Serial (more on my hardware below)
Put the BC127 into Command Mode by sending “$$$$”
Put the BC127 into DFU mode by sending it “DFU\r” as per the notes on the Firmware Upgrade Tool webpage (why this info is not in the application note is curious)
Watched some ascii garbage on the serial port
Disconnected serial port and launched Melody Updater
Found serial port
Failed to connect…
Here’s a screenshot

Screenshot 2020-11-18 084558 DFU com fail

I went back through the process, and checked my steps. When I went to verify the response from sending “DFU\r” I got the following HEX values from the BC127


This is clearly not the characters 0xAA 0x52 as stated in the webpage notes.

Back to the beginning, I simply put the BC127 into Command Mode and then connected via Melody Updater. Now I’m able to connect! So I select the latest firmware version, and press upload. The Melody Updater said it was putting my BC127 into DFU mode, and then it failed. Happily, it gave me an error!
Error 88 “failcom_connect”

Thinking that this might be a version issue (since my firmware is so old that Sierra Wireless doesn’t think it’s worth wile supporting it with user manuals, even) I then tried to update to an earlier version 6.1.5. I got the same error.

Do I need an earlier version of the Melody Firmware Upgrade Tool?
Do I need to implement flow control on the UART? (I notice that this hardware follows the ‘sometimes ya do, sometimes ya don’t’ rule)

I notice that all of the documentation is referencing something that looks like the BC127 dev module. It appears to have the BC127 interfaced with the USB port via an FTDI USB<>Serial IC. I’m very familiar with this setup. My hardware target BC127 is not interfaced with an FTDI chip. It is on a board with custom hardware that I designed for the Tympan www.tympan.org. You can find details on the Tympan hardware design at https://github.com/Tympan/Tympan_Rev_D_Hardware. The basic coms connection is the UART of the BC127 is connected to a UART of the Teensy 3.6 variant on the board, and the Teensy 3.6 variant is showing up as a COM port on the computer. I have code running on the Tympan that is acting as a Serial Port pass-through between the Computer, so anything sent from the computer on the COM port is passed directly to the BC127 and the opposite too. I’m able to communicate directly with the BC127. I can put it into Command mode, Data mode, I can read the version (as listed above) etc.

I did try to download the Melody Firmware v 6.1.2, but the browser timed out. Seems that’s not supported even though it’s been linked to? Or the link is broken?

UPDATE: I did get the 6.1.2 firmware to download. It just took a looooong time.
Same process, same issue: Error 88 “failcom_connect”

Really hoping that there’s a simple answer to this problem.

Hi biomurph1

I can successfully upgrade the BC127 to Melody firmware 7.3 version.
Please refer to BC127: Error during the Firmwareupgrade with Melody DFU for your reference.