Any AT+WIPxxx command replies with 'ERROR'


#1

Hi, there!

After upgrading q2501 with v6.57 FW and uploading “AT Wrapper” (ads_AT_wrapper_2_00_06.wpb.dwl) module replies with “ERROR” even on AT+WIPCFG=3 command. Am I doing something wrong?

Thanks,
Mark


#2

It may be because the TCP/IP is not enabled on your module. Even though the TCP/IP is meant to be enabled by default in 657 upgrading from 65x to 657 will not get it going if the original firmware was not enabled.

You can check by AT+WCFM=5

If the last digit is a 1 then it is enabled.


#3

Hi,

I have the same problem on my Q24NG Plus module. I ran the at command and the last digit is 1 - so it is enabled… but still the module replies with an error to all wip commands. I’m at loss to explain why.

Will appreciate all help.

R


#4

Hi,

Have you entered AT+WOPEN=1 to activate the wipSoft ?


#5

Hi Wallace,

I tried that just now AT+WOPEN=1 returns OK. I then enter AT+WIPCFG? reply is ERROR so problem remains :angry: I’m getting frustrated

R

PS: ATI3 response: 657_09gg.Q24PL003 1954500 102706 18:44


#6

You have to start the TCP/IP stack with AT+WIPCFG=1


#7

Hey All,

I’m also experiencing the same issue as Mark and Ritesh with my Wavecom Q24 Plus modem. Has any progress been made on this issue or has anyone managed to find a workaround?

Since we are upgrading our software to use the new modem and WIP software from the Q2406B this really is a showstopper if basic connectivity cannot be initiated.

Any help or hints and tips would be greatly appreciated!

Cheers,

…graham.


#8

Hey All,

Just thought I’d post to say that the issue here is that the WIP software is not actually installed on the device! Apparently some of the early sample units shipped without the software on-board. You’ll have to contact your Wavecom distributor to obtain the firmware you’ll need to transfer to the unit.

Hope this helps anyone else who’s stuck!

…graham.