Airprime Q2687RD compliance tests


#1

Hello,

I’ve been trying to connect the Airprime Q2687RD to Agilent 8960 for compliance tests (3GPP). The only thing I need to do is start a call (either from the dut or Agilent 8960) and answer it.

I was able to make the module register in the Agilent test network, however Agilent 8960 does not identify the device, so it cannot start a call. On the other hand, when I try to start a call from the device (AT123), it answers “NO CARRIER”.

AT+GSMINFO
+GSMINFO:
NETWORK REGISTRATION STATE: REGISTERED, HOME NETWORK
PROVIDER NAME: Agilent TS34.108
SIGNAL QUALITY: -67 dbm

OK

I can start the call normally when using a local carrier (Vivo):

AT+GSMINFO
+GSMINFO:
NETWORK REGISTRATION STATE: REGISTERED, HOME NETWORK
PROVIDER NAME: Vivo
SIGNAL QUALITY: -77 dbm
+STAPPLI: 0

+CRING: VOICE

+CRING: VOICE

ATA
OK

The laboratory technician suggested the Agilent 8960 network might be blocked on this device. Could this be the problem?

Any ideia on why this is happening?

Thanks!


#2

Hi @lmizuta

Even though Q2687RD has been EOL since many years already it should be able to register on RF tester and establish a call. There is no restriction on this.

Remember that Q2687 is a 2G only product. You cannot establish any 3G or LTE call.

Back to your explanation, the AT command you use does not seem to be a valid Q2687RD AT command. Can you double check this point?

Can you also provide the firmware version running on your device? For this you can use

ATI3

Registration status?

AT+CREG?
AT+COPS?
AT+CPIN?

Lastly, if you want to establish a voice call you need to add a semicolon after the phone number. For example to call number 123 the exact command will be:

ATD123;

Let me know if it helps


#3

@bbo thanks for your reply.

I apologize for the late reply. I had to schedule another meeting with the laboratory to repeat tests.

This time, I did the tests using a CMU200 (from Rohde and Schwarz). Unfortunately, Q2687RD did not register to the network at all.

ATI3
R7.43.0.201003261552.Q2687RD 2139952 032610 15:52

AT+CREG?
+CREG: 2,2

AT+COPS?
+COPS: 0

OK

AT+COPS=?
+COPS: (0,“Agilent TS34.108”,“Agilent”,“00101”)

AT+CPIN?
+CPIN: READY

Signal quality is usually around -61dbm.

Apparently, there is a APN configured in this device, which may be making the device reject the registration in the test network. I checked it with these AT commands:

at+cgdcont?
OK

at+cgdcont=?
+CGDCONT: (1-4),“IP”,(0-1),(0-1)
+CGDCONT: (1-4),“PPP”,0,0

It doesn’t seem to let me exclude the APN though.

at+cgdcont=1
OK
at+cgdcont=2
OK
at+cgdcont=?
+CGDCONT: (1-4),“IP”,(0-1),(0-1)
+CGDCONT: (1-4),“PPP”,0,0

OK

Any ideas on why this is happening?

Thanks a lot!


#4

Hi,

The APN is not going to have any influence on whether the unit is able to attach to it or not (as with LTE).

The key point here is that the unit can see the test set but is not attaching to it so the question is why, can you have the below commands sent to it while connected to the test set?

at+cmee=1
at+cimi //This will show the IMSI of the SIM card so we can see if it is going to be attaching as a ‘home’ SIM
at+cops=1,2,“00101” //This will force the unit to perform an attach and will hopefully provide a reject cause.

Regards

Matt


#5

Hi Matt,

Thanks a lot for your reply.

During the tests, I checked the IMSI of the SIM card:
IMSI: 001012345678901

Can you tell if there is something wrong by this number?

Regarding the other commands, I will re-schedule the tests and check the results.

Thank you very much!

Kind regards

lmizuta


#6

Hi,

from this we can see you are not registered on the tester.

Another point I can think about is related to the tester configuration. By default the Q2687 will only try to attach to Circuit Switch network (used for voice call and CSD data call). You can force a registration to PS network with AT+CGATT=1

Is your Agilent tester trying to attach in both CS (Circuit Switch) and PS (Packet Switch / GPRS) ?

You can try to activate automatic registration to both CS and PS:

AT+WGPRS?
AT+WGPRS=0,0
AT+CGCLASS="B"
AT+CGDCONT=1,"IP","apn"

>> check what your tester expect as APN but I expect it should be very permissive

AT+CREG=1
AT+CGREG=1
AT&W
AT+FUN=1,1

The last command will reset the module.

If the device can register to PS network you should see +CGREG: 1,1 indication

You can refer to AT command guide for more details on the various commands used above:
https://source.sierrawireless.com/resources/airprime/software/at-commands-interface-guide-for-open-at-application-framework-firmware-7,-d-,52/

this AT command guide is not referring to the exactl same firmware you are using, but it should be enough to get details on above commands.

Let me know how it goes


#7

Hi @bbo,

Sorry for the late reply!

I was able to make the module connect to the test device by setting manual registration mode.

at+cops?
+COPS: 1,0,“Agilent TS34.108”
at+creg?
+CREG: 2,1,“0001”,“0000”

The test device was able to see the device and read its IMSI number, as you can see in the following photo:

However, I can’t start a call from either side (“Originate Call” button from Agilent 8960, or “ATD” command from the module).

atd123; //According to the lab technician, I could start a call to any number.
NO CARRIER

Available networks:
at+cops=?
+COPS: (2,“Agilent TS34.108”,“Agilent”,“00101”),(0,“TIM BRASIL”,“TIM”,“72403”)

Registration to PS network:
at+cgatt=1
+CME ERROR: 148 // Unspecified GPRS error ?

Please see following the responses to the other commands:

at+wgprs?
+WGPRS:
+WGPRS: 1,0
+WGPRS: 2,0,1
+WGPRS: 3,0
+WGPRS: 4,10
+WGPRS: 5,0
+WGPRS: 6,0
+WGPRS: 7,0
+WGPRS: 8,10
+WGPRS: 9,0,0
OK
at+wgprs=0,0
OK
at+cgclass=“B”
OK
at+cgdcont?
+CGDCONT: 1,“IP”,0,0

Any suggestion on why this is happening?

Thanks a lot!

Best regards,
Lucas


#8

Lucas,

The unit is CS attached (CREG response) so in theory it should be able to place a call to the test set (not a PS session).

If you send the following what happens?

at+cmee=1
atd1234567890;

Note the ; also indicates a voice call so the test set might not like seeing a voice call, only a data call. Do you see any flicker on the test set in the ‘Active Cell’ window when trying to make the call?

Regards

Matt


#9

Hi Matt,

Maybe the test set tries to make a data call when we pressing the “originate call” button? And since it cannot connect to PS, call cannot be completed?

at+cmee=1
OK

atd123; //According to the lab technician, I could start a call to any number.
NO CARRIER

Registration to PS network:
at+cgatt=1
+CME ERROR: 148 // Unspecified GPRS error ?

I will check with the lab if it is possible to select if the call is PS or CS.

Forgot to mention, there is no flickering on the test set in the “Active Cell” window.

Thanks a lot!

Kind regards,
Lucas


#10

@lmizuta,

The CME errr 148 is a catch all error which is a problem determining what the issue is. The unit is also really old (2010 for the 7.43 firmware) so that might be having an impact.

Regards

Matt


#11

Dear all,

I scheduled the test in other lab just in case. To my surprise, the module attached to the test unit (CMU200) network and stablished a CS call without any problem, in all frequencies.

I don’t know much about the settings of the test unit, but in any case the issue is solved, hopefully without any further problems.

There was no need to do any additional setting to the module (aside from changing the operating bands, AT+WMBS).

Thanks a lot for your support!

Kind regards,
Lucas