Q2687 Network Registration Time

We have got more and more customers that send their units with an AirPrime Q2687 back for repair, claiming that those units do not connect to the network anymore. Those units have been in operation for years without any problem, this issue was noticed only recently.

As our repair center could not find a problem in the units, I took out the Q2687 module and put it onto an evaluation kit. the firmware our customers use is 7.45, however, just to note this right here, I updated the firmware to 7.52 and the behavior was the same.
(The reason we are still on 7.45 is the following: On those modules, update to 7.52 via XMODEM fails with an error, but this is another topic.)

The problem seems to be that, from power up, the network registration time can be as short as 4 minutes (what, in my option, is actually already long) but sometimes goes up to 30 minutes!

At my workplace, there are 5 networks visible, one has no 2G access, two are forbidden, and the other two have still 2G support. The home network of the SIM card is one of them, which is Vodaphone.

After registration is done, the signal level seems reasonable at level 14 (=-85dBm).
I’ve created a batch file that logs the network status ever 5 seconds. It starts with this entry:
27.08.2021 16:11:29.69
+COPS: 0
+CREG: 0,2
+CSQ: 99,99
continues like this till the module has registered:
27.08.2021 16:22:10.67
+COPS: 0,2,26202
+CREG: 0,1
+CSQ: 12,99

Why could it be, that network registration takes such a long time?
Could this be related to more and more 3G, 4G and even 5G networks being around?
Is there and way to speed up this network registration?
Is there anything I can go to get more information on this issue?

Thanks, Martin

You can try to use +cops in manual mode and see if there is improvement

Thanks, I tried this last week but it did not work, I always got an ERROR response.
But now I think it was the syntax:
instead of
The examples in the documentation do not use the quotes, but I’ve seen this in other places.
Is this correct?
Unfortunately, today I’ve got no access to the system, but I’ll test it tomorrow.

Looks like this command only works after the modem has already registered to the network. Otherwise it’s giving back ERROR.
Does not make really sense to be. Any idea?

You can see it after registered and then reset it and see what happens

So far I’ve not seen any time above 8 minutes (10 cycles). But this is still very long. Imagine your mobile phone would take this long to connect after switching it on!
What could be the reason it starts to take this long?

do you mean there is improvement after using manual mode in +COPS?

So far it looks like, as I did not see any time above 8 Minutes. I mean 10 samples is not a lot, but still.

As problem is found only recently, maybe some base station setting has been changed

Actually, it’s unlikely, as the customer sees the same problem, but is hundreds of kilometres away from the place I’m testing. Therefore we are not connecting to the same base station.
What is considered as a usual, ‘reasonable’ network registration time?

Do we have standard on that?

Btw, you need to consider why it is working fine in the past

No, I do not have any standard on this, but for me it’s common sense. Who want to wait 4 to 8 minutes after switching on his mobile phone, before one can use it?

Anyway, I put the SIM into a regular old GPS phone (Siemens S65, and yes, it’s still working). After inserting this card, the first time I switched on the phone, it took a very long time (more than 4 minutes) before it registered to the network. The display was shoring ‘Network Search’.
However, after switching off the phone and powering up again, it took only a few seconds to register.

So there must be a difference between first time registration and follow up registration from a modem.
Is there anything I can do to make the Q2687 work the same way?

you can try to upgrade to newest FW and see if problem still exist.

As mentioned above I tried with 7.45 and 7.52 already, which I believe is the latest version.

have you checked if you are using correct band by AT+WMBS?

Sorry, but what am I supposed to do with this command?
+WMBS: 7,0

Would limiting the bands help?
How would I find the correct band?

7 mean Quadband.
You mean if I limit to 900 MHz only, this could be the solution?
I assume this would be fine for 2G, as those still in operation should work on this frequency only, correct?

You need to make some test on different parameters and see if there is improvement