Q2686RD running properly in Europe, not in Canada

I have a device on which a Q268RD is used for 2G connection. It worked well in Europe.
I’ve sent it to Canada, changed the antenna (850/1900), put a proper Rogers’ SIM card, checked that a 2G network is available in my place, but no way to get it running properly.
AT+CSQ return 99,99

Any idea ?

Did you also set those bands in the Q26 :question:

How, exactly, did you check that :question:

What does AT+COPS=? tell you :question:

:open_mouth: I have to do so !?
I’ve just check on the documentation. You’re probably talking about AT+WFM command.No I didn’t.
I thought that it was enabled by default. I’ll check on the device…
Thank you for this information.

I’ve checked 2G availabity with a mobile phone (Switching 3G off) and another 2G/GPRSonly modem. Did file transfer with no issue with both.

In additional, please check +WMBS also for band setting.

AT+COPS=? mentioned by awneil is good too to show which carriers are in coverage.

Bands settings was the issue. I’ve setted the US ones with “AT+WMBS=4,1”, restarted the modem then it was able to get a signal, an operator etc.

But I still get an issue (I guess) the modems takes a very long time to be register to the network when switched OFF then ON again. It takes a randoms amount of time, between 1 minutes up to 8 minutes. I think this is not a normal behaviour.

When searching :
+COPS: 0

+CSQ: 99,99

+CREG: 0,2

+CSQ: 99,99

Then the modem registers and everythings goes well…

In Europe, I’ve never seen a registration that take more than 30 seconds… Any idea that could improve this ? At least an explanation ?

You should always detach cleanly from the network rather than just powering off.

When it registers, is it Roaming :question:

I was not switching off the modem properly. I think that it was negociating something with the operator after each power up. It could be the “Bearer type selection” (See AT+CBST) because I’ve noticed that this value changed from 0 (Autobaud) to 7 (9600/V32) before the fix. Now, it switchs to 9600/V32 immediatly.

To fix it, I’ve waited that the modem properly connect to the operator (took 3 minutes) then detached with “AT+CFUN=0”.

Problem solved.

Thank you awneil, your help is priceless.
Glad you’re still active on this forum !

You’re welcome