adl_atCmdCreate Problems


#1

Hi,
i have a problem with adl_atCmdCreate() too. My intention is to get the response of at+cced=1,7 into an ascii string for further processing.
The response looks as follows:

+CCED: 262,02,0319,03fd,25,73,35,,,0,,,0,262,02,0319,2581,28,10,15,262,02,0319,03ff,30,76,14,262,02,0319,,63,105,11,2

What i tried is as follows:

static ascii *resp

bool adl_cced_response_handler ( adl_atResponse_t *cced_pars)
{
resp = adl_strGetResponse ( cced_pars->RspID );
}

void adl_main ( adl_InitType_e  InitType )
{
adl_atCmdCreate( "at+cced=1,7",FALSE,(adl_atRspHandler_t) adl_cced_response_handler,"*",NULL);
}

unfortunatly i get “OK” in my resp-pointer but +CCED:… response withstands persistantly.

can someone help?
cs


#2

cced_pars->StrData holds the response string.

regards,
Arfy


#3

Hi people,

Has anybody had problems with the unit resetting itself when creating this internal command “at+cced”?

My open at app constantly resets itself everytime “at+cced” is executed.
This includes when typing “at+cced” from hyper terminal while my application is running.

Obviously it doesn’t crash when the app is not running.

I would llike to hear your opinions.


#4

Hi Yul,

I have the same problem with X.51 / OpenAT 3.02. When sending the command “at+cced=0,1;+cced=0,4;+cced=0,2\r” the application crashes. There is no problem with the same command when we are using OpenAT 2.0!

That’s right! When we type in the same command when the application is stopped it works just fine!!

We haven’t found a solution - I think this is a bug…

Best Regards,
Jan


#5

thanks a lot Arfy,
whenever its hard to see such an simple solution for my problem.

cs :bulb:


#6

Oh dear… I hope Wavecom development guys are aware of this problem.


#7

Hi Yul,

I think it is fixed in X.55 / OpenAT 3.10. I just tried our application with this core firmware and so far it seems to work fine with the CCED commands…

Best Regards,
Jan


#8

Hi Jan,

Yes you are right!! at+cced=0,1 all works correctly while OpenAT application is running. Thanks Jan.

Yul


#9

I just discovered that it also works in 6.52 (OpenAT 3.03)!

Best Regards,
Jan


#10

Where can I download 6.52 (OpenAT 3.03) ??

Best Regards,

Henrique


#11

Hi Henrique,

I think you’ll need to get the SDK’s and core firmware from your distributor (the place where you got the module)… I got it from our distributor…

Best Regards,
Jan