adl_atCmdCreate bug. Receiving the same string


#1

I found strange behaviour of adl_atCmdCreate command.

I’m using q2686, openat 4.20, os 6.62.

I needed to acquire gsm level, so I made 10 sec cyclic timer and in the body of the cycle I put this command:
adl_atCmdCreate(“at+csq”, FALSE, (adl_atRspHandler_t) CsqHdl, “*”, NULL);

This command worked until I decided to check how it changes depending on the state of antenna. So I removed the antenna and I’ve got the level of 99,99. It seemed OK but after I reconnected the antenna this level stayed the same. I checked it manually with at+csq and it showed that the level is ok, something like +CSQ: 21,0. So adl_atCmdCreate began to generate the same line +CSQ: 99,99, not regarding the real level…

After another couple of experiments I found that the response for this command can stuck without disconnecting the antenna and it can stuck periodically and even permanently.

Does anybody have solution for this problem?


#2

Ok.
The bug is still here by I found a workaround.

At the every start of application I run the command at+cced=1,8,1 and subscribe for +csq unsolicited string. Handler for +csq parses data and I get precise information about GSM signal level.