Access to FTP server via Q2698 module

Hello every one,

I would like to access to my FTP server installed on my PC via the Q2698 module. But I don’t know how to do this.

First, I have to have an internet connection on my PC via the module. So, i tried with AT commands (at!scact=1,1), sometimes it works sometimes not. This depends if the CID is created or not and mostly the CID=1 is not created even if my APN parameters were correct.
Another try was with the gateway sample provided in developer studio, but it seems there is a firmware issues (69259 in release notes for firmware 7.52.0.A1).
So, i downloaded the AirCard Watcher sofware to solve this problem.
Now, I have an internet access on my PC via the module using this software.

But, now I would like to access to files in this PC via FTP protocol. So I created a FTP server, configured the firewalls and use some OpenAT functions in module to forward packets. I used the wip_netInit() and wip_netInitOpts() functions to put default values and WIP_NET_IP_FORWARD to TRUE.
Then, I used the wip_ipFwdEntryAdd() function to forward the TCP packets for FTP with the internal (private) IP address, external (public) IP address, the port 21 and IPPROTO_TCP as parameters of this function.

So, I don’t kown why I can’t access to my files in FTP. The FTP server has been tested through a local server and is working well.
Any ideas ?


Module : Q2698
Developer Studio :
Open AT Application Framework package : 2.52.0.A1
Open AT OS package : 6.52.0.A1
Internet Library package : 5.56.0.A1
Firmware package : 7.52.0.A1

is the FTP in some LAN? or is it a public FTP?
Are you able to ping FTP from module?have you tried wipsoft application… ?
at+wipping command… hope this should work…


Thank you for your reply.

I’ve got a FTP server on a local PC, which is currently accessible from LAN. Now I want to use Q2698 in order to have an access from outside. So, my server (PC with FileZilla server software installed) is connected to the 3G module (Q2698) via USB. I have an Internet access to my server thank to Sierra wireless AirCard Watcher software.

After your post, I tried to use the at+wipping command. So, I downloaded on my module the WIPSoft application and tried the command. It replied an error 803 : “Operation not allowed in the current Internet Library stack state”. I searched on the forum what means this but I didn’t succeed to find something interresting.

Do you know why this happens ?