[FXT009] AT Commands to open FTP connection

Dear all,

I’m having troubles to open an FTP connection via AT Commands. I’m working with the FXT 009 AirLink Programmable modem.
I need to do this with AT commands as in the futer I will drive this modem via a serial RS232 interface from our own system (PCB).

I’m wondering what the exact comments are to open this connection. Especially for calling.
Some info:

  • Provider: mobistar (Belgian operator)
  • APN: web.pro.be
  • APN username: mobistar
  • APN password: mobistar
  • FTP host: “”

I suppose the following is the correct PDP context.

+CGDCONT: 1,"IP","web.pro.be",""",0,0

When I try dialling using ATD99**1# I’ll get the following

CONNECT 115200                                                                                                                      
~ÿ}#À!}!}!} }6}!}$}%Ü}%}&} } A§}'}"}(}"}#}$À#ñc~~ÿ}#À!}!}!} }6}!}$}%Ü}%}&} } A§}'}"}(}"}#}$À#ñc~~ÿ}#À!}!}!} }6}!}$}%Ü}%}&} } A§}'}"}
(}"}#}$À#ñc~~ÿ}#À!}!}!} }6}!}$}%Ü}%}&} } A§}'}"}(}"}#}$À#ñc~~ÿ}#À!}!}!} }6}!}$}%Ü}%}&} } A§}'}"}(}"}#}$À#ñc~~ÿ}#À!}!}!} }6}!}$}%Ü}%}
&} } A§}'}"}(}"}#}$À#ñc~~ÿ}#À!}!}!} }6}!}$}%Ü}%}&} } A§}'}"}(}"}#}$À#ñc~~ÿ}#À!}!}!} }6}!}$}%Ü}%}&} } A§}'}"}(}"}#}$À#ñc~~ÿ}#À!}!}!} 
}6}!}$}%Ü}%}&} } A§}'}"}(}"}#}$À#ñc~~ÿ}#À!}!}!} }6}!}$}%Ü}%}&} } A§}'}"}(}"}#}$À#ñc~                                                

Which is the PPP negotiation. But should I answer to this manually? Or can it be done automatically using some AT command settings?
I already tried AT+WPPP (with the correct username and password) without succes.

Or is there an other way to set-up the FTP connection?

EDIT: AT+WIP commands are resulting in errors, should I install some package for this? The installed packages are:

"DWL","V10c05","","Sierra Wireless",62640,"051513 10:45","a0836b50","00010000"  
"FW","FW_752_34_3.Q2687RDG","R7.52.0.201306260837.FXT009","Sierra Wireless",6734
36,"062613 08:37","89796368","001d0000"                                         
"MODEM","1.3.36","201306260837.FXT009","Sierra Wireless",1713240,"062613 08:37",
"OAT","v1.3.20130627140543","Extended AT Application","Sierra Wireless",1526724,
"062713 14:05","994a69ab","002a0000"                                            
 -"Developer Studio",""                                
 -"Open AT OS Package",""                                    
 -"Firmware Package",""                                      
 -"Internet Library Package",""                              
 -"Location Library Package",""                               
 -"Security Library Package",""                               
 -"eCall Library Package",""                                  
 -"Jamming Library Package",""                                
 -"ExtendedATApplication Library Package",""                  

So my main question is if someone can provide me an example of AT commands to set-up myFTP connection, using the FXT009.
(I already searched a lot via google but couldn’t find a working example)

Many thanks in advance!

Look in this document in section 9.4.


That’s what I already tried.

But as explained in my first post AT+WIP commands are always returning “ERROR”.
So it seems that the modem doesn’t recognize this commands.
Therefore I asked the question if it is neccessary to instal some other libraries on the modem and how to do this.
The “ExtendedATApplication library package” and “Internet Library Package” are installed and I suppose these should understand the WIP commands…
But for now that’s not the case…
What to change/do?

Is the extended at application running, check with
If it returns 0 start it with