WP7607 isn't working with all SIM cards

I’ve encountered an issue where some SIM cards refuse to connect to operators network no matter what 3gpp profile I use.

For context. In my country we have 3 providers: TELIA, BITE and TELE2. They provide SIM cards for a subscription based service to clients.
Also each of those providers offer pre-paid SIM cards: EZYS, LABAS, PILDYK respectively that use same 3gpp profiles and have same MCCMNC as their subscription based counterparts.
For instance:
Telia = Ezys → MCC 246, MNC 01, same 3gpp settings

But when I tried testing all of the SIM cards, these were the results:
TELIA - connects and works fine
EZYS(telia) - connects and works fine
TELE2 - connects and works fine
PILDYK(tele2) - SIM card won’t initialize, sim no recognized (tried 2 different SIMs)
BITE - Connects to network but no access to internet
LABAS(bite) - doesn’t connect to network, keeps timing out/no service (tried 2 different SIMs)

Test setup:
Custom PCB with WP7607-1 modem connected to windows laptop via USB
Firmware version: R16.0.1 (Sierra Wireless — GCF) (also tried with R16.0.1 (Generic — GCF & PTCRB))

Also tested on a random tp-link 4gLTE router. Wasn’t able to test all of the SIMs, but the ones that didn’t work with WP7607 are working with the tp-link router.

What is the problem here? Why connectivity varies so much based purely on a chosen SIM card?

Hi eimantas,

WP607 may be not compatible with some network carriers. You could check your network carrier frequency at https://www.frequencycheck.com and compare it with the table below:


Checked the website you provided, but also looked around for official sources on frequency, to be sure, and found our country’s Communications Regulatory Authority paper on frequency use.
Seem to me that our carrier frequencies should be supported by the modem. Except for the B20 band, doesn’t seem to match up very well. Seems like a typo; RX bands are in TX column and vice versa. Is that significant? How do I test for it?


Can you run the attached teraterm script (its a text file) or send the command manually and post the result for the SIM’s that don’t work? Given the unit can see and attach to the local networks using some of the SIM cards its not going to be a configuration or SIM rights issue (or maybe a hardware one the commands might highlight this).

WP76 status.ttl (1.3 KB)



Hi. I tried running the commands you provided. Manually though, because I couldn’t befriend teraterm.
Here are pastebin links, because I still can’t upload attachments to this forum:

Not working sims:
pre-paid LABAS(BITE): LABAS - Pastebin.com - won’t register into the network, no service.
pre-paid PILDYK(TELE2): PILDYK - Pastebin.com - SIM won’t initialize/no sim detected

Working sims:
pre-paid EZYS(TELIA): EZYS - Pastebin.com - Can connect (but currently can’t access internet because needs to be topped up)
subsription TELIA: TELIA - Pastebin.com - works fine
subscription TELE2: TELE2 - Pastebin.com - works fine
subsription BITE: BITE - Pastebin.com - works fine

Anything else I could try?