WIPAT Problems on SL8080T


I just both an SL SERIES on the online store of this web site. I quickly received the pack, and I started building the AT command scrip for my application.
For now, I’am using the SL8080T and I’am trying to perform an HTTP Post, or at least to send an email… successfully :slight_smile:. I get strange responses for the AT+WIP commands. I can open the GPRS bearer and ping distant hosts (i.e. Google.ca), but the data transfer operations (+WIPFILE and +WIPDATA] does not work proprerly. I also have problems when I try to connect with my usual SMTP server . I can’t figure out what I am doing wrong. Maybe the Beta version of the Internet Library I am using does not support the most recent WIPAT commands?
Here are some loges/traces of my tries:


“DWL”," S4_1_0_7BT R1431 CNSZXD00000155 2012/11/19 16:06:52","",“Sierra Wireless”,0,"",“00000000”,“00000000”
“FW”,“FW_750_20_A1_25.SL808Fx”,“R7.50.0.A1.201212171435.SL8080T”,“Sierra Wireless”,1670256,“121712 14:35”,“648de921”,“10002020”
“MODEM 3G+”,“Revision: S4_1_0_7AP R1431 CNSZXD00000155 2012/11/19 16:06:52”
“OAT”,“v5.53A1”,“Internet Application”,“Sierra Wireless”,185780,“110712 11:16”,“df162932”,“10700000”
-“Developer Studio”,“”
-“Open AT OS Package”,“6.50.0.A1.201208171740”
-“Firmware Package”,“7.50.0.A1.201209271014”
-“Internet Library Package”,“5.53.0.A1.201211071103”

Example of problems:



+CME ERROR: 865 //"authentification failure (??)

The strange is that I get a positive response this :

AT+WIPCREATE=6,1,“smtp.live.com”,25 //no username no password




… latter on : +CME ERROR: 850 //invalid channel option or parameter value

The for WIPFILE command, the application don’t seems to enter the data mode:




AT+WIPOPT=5,1,2,51,1024// set TX buffer size

AT+WIPOPT=5,1,2,50,1024// set RX buffer size


(No CONNECT no +CMEE ERROR), the application does not enter the data mode. I also have

+CMEE ERROR 846 // internal error: FCM subscription failure …

Thanks in advance,


The SMTP problem with live.com server is that it required TLS authentication, STARTTLS, AFAIK it is not supported…

Try yahoo server to see any luck or refer to below:

Hi lotam,

Thanks for your response, The SMTP connection I wanted to establish, was to check if any data transfer is possible using the SL8080T. What I’m really interested in, is to perform HTTP POSTs. I tried several things, but as I said previously, the internet application never enters the data mode.

This Post is the most relevant think I found concerning the HTTP socket creation, I followed the last suggested method but I’m still facing the same problem. An FCM internal Error (+CMEE ERROR 846)

There is other modules in the development kit I both (i.e. SL6087), when using this module instead of the SL8080T I can’t even start the GPRS bearer!!! (+CME ERROR: 3) wish is a SIM related ERROR.

Shill I work with other modules instead of the SL Series?

Thanks in advance

Hi yaeli,

I am not able to repeat the error 846 using latest FW.

Maybe worth to test using latest FW and WIPSoft because the one you are using is almost 1 yr old.

I attached my test log for reference.

Hope it helps.

Thanks for your prompt response!

I just tried this with the SL8082T, but strangely I am not able to start the bearer. I can get a positive response to the AT+WIPBR=4,6,0 command for the SL8080T but not for the SL8082T. Is this related to signal strength? This can make sense if the SL8080T has much better sensitivity comparing to the SL8082T.

In addition, I can’t find the version of the Firmware Package you are using. The most recent Open AT Application Framework Package I can found on the “Default Sierra Wireless Repository” is I can’t download this Firmware to the SL8082T because it’s “not compatible with SL808x module”.
Nothing happens when I refresh the repository (right click -> refresh selected repositories). How can I get the latest version to test your AT Commands set and have solid base for comparison?

When sending AT+WIPBR=4, 6, 0 the internet application reply with +CMEE ERROR: 812, between 30 seconds-1 minute later… I try to give the maximun of indications, to make the problem solving easier… I absolutely need to fix that issue before going further in my application development! I edited this post several times today, hoping that the next reply will be helpfull. I would like to precise that I am a “noob” at M2M, BUT I spend more that 40 hours in 3 weeks trying to perform an HTTP post… what do you thing about that ?



I temporary solved the problem! But knowing the cause of the FCM internal error (+CMEE ERROR: 846) makes me mad! It’s all about developer studio … when I use putty I can POST and GET using HTTP…
Actually Developer studio is more ergonomic than putty, I want to properly use developer studio, so please tell me if there is any version that handles the FCM! I’ll also try to use an RS232 instead of USB for serial communication, but the USB works with putty.