HTTP connection using +WIP AT commands


#1

I’ve tried several times to connect to HTTP site via +WIP AT commands but in vein.

I followed the example given in the WIPAT_COMMANDS_USER_GUIDE_V3_11:

at+wipcfg=1

OK
at+wipbr=1,6

OK
at+wipbr=2,6,11,“APN”

OK
at+wipbr=2,6,0,“internet”

OK
at+wipbr=2,6,1,“internet”

OK
at+wipbr=4,6,0

OK
at+wipcreate=5,1,“www.google.com”,80

+CME ERROR: 3
at+wipcreate=5,1

+CME ERROR: 3

I don’t know where is the problem. every at+wipcreate gives error 3
please help


#2

Hiya,

Looks like the bearer connection has failed. Have you got the correct APN/Username?password for your ISP? Is your SIM card enabled for GPRS Data?

Have you enabled AT+CMEE=1? It looks like you have, but I can’t find any indication of what +CME=3 indicates. All the WIP CME errors are around 800 or so.

ciao, Dave


#3

yes ,that’s the strange thing.

that was on “Q24 Plus” module.
but I’ve tried the same on another module “Q2687” and the +wipcreate works wright now.
I don’t know what’s the difference between both modules.

but still I can’t get any data from any site using the +WIPFILE command.

I receives error 831 (bad state)


#4

Hi,

We have the same problem with a Fastrack Supreme 20.

We try to connect with HTTP, FTP, SMTP but we have ERROR 3 with the WIPCREATE command. WIPCREATE works well only with UDP or TCP sockets connections but when we try to send data (wipdata), our wavecom make a reboot.

here our AT commands listing:

at+cmee=1
OK
at+cpin=0000
OK
at+cgatt=1
OK
at+cgact=1,1
OK
atd99**1#
CONNECT 115200

+++
OK
NO CARRIER

at+wipcfg=1
OK
at+wipbr=1,6
OK
at+wipbr=2,6,11,“APN”
OK
at+wipbr=2,6,0,“login APN”
OK
at+wipbr=2,6,1,“password APN”
OK
at+wipbr=4,6,0
OK
at+wipcreate=1,1,80,“www.wavecom.com”,80
OK
+WIPREADY:1,1
at+wipdata=1,1,1
CONNECT

+WIND:13
+WIND:4

We must redo all the sequence to retry a connection.
Without the atd99**1#, the at+wipbr=4,6,0 don’t work.

The french technical support don’t be available since one week. Can you help us please?

Thanks a lot.

Celine.


#5

Do you have the Internet Protocol Option enabled?

See: viewtopic.php?f=16&t=3622&p=14001&hilit=internet#p13946


#6

Thanks for your answer.

at+wcfm=5
+WCFM: 00000030,0
OK

So if I understood well the user guide, my wavecom have:
Real Time Operating System (0x10)
Open Sim Access (0x30)

but not Internet Plug-in (0x01). I will contact our distributor.

Question: what is ‘Orange M2M Connect’? Our SIM distributor is Orange (France): is it the same ‘Orange’?

Thanks.

Celine.


#7

I think it’s a specific service from Orange?


#8

I am new and I don’t know how to solve the problem. But I found out that +CMEE 3 error means “the operation is not allowed”. Therefore, it seems like the steps above are not right yet.
Cheers!


#9

Hiya,

OK, sounds like your modem is not enabled for the Internet Protocol Commercial Service. Check the results of AT+WCFM=5 (and see the above post for another user with the same issue). If the modem is not enabled for Internet Protocol, you’ll have to go back to your distributor to get it enabled.

ciao, Dave