WIP library problem with Q2686


#1

Hello boys and girls,

I have a problem with running the InternetConnection sample with the Q2686 module. When I build it in RTE mode, I get the following error:

… Link mingw_InternetConnection_H.bin …

make: *** [make_single_bin] Error 1
rte_wmwip_2.0.0.2.0.lib(./rte/vc6/Release/st_rand.obj)(.text[_ngRandom]+0x25):U:\projet\gsmmi\in: undefined reference to _allmul' rte_wmwip_2.0.0.2.0.lib(./rte/vc6/Release/st_rand.obj)(.text[_ngRandom]+0x33):U:\projet\gsmmi\in: undefined reference to_aullrem’
Done.
Updating RTE kernel file…
no generated DLL found…
[wmmake error #1] Build error.

If I build in Target mode, it can be built, but after downloading it on the module I get only an ERROR message, and not even the traces in the main function can be seen.

I also encountered some strange problem when I build the QueryApp sample project including WIP 2.0.0.2.0 – it simply crashes when trying to link mingw_QueryAPP_H.bin, saying that “ld.exe” has encountered serious problems… But if I do not include WIP, it runs ok.

Anybody has an idea?


#2

Same thing in OpenAT 3.13 and rte_wmwip_2.0.0.6.0.lib. Anybody solved this issue?


#3

Not exactly the same problem I’ve experienced but quite similar.
In my case, it was caused by spurious files in the src subfolder of the project. If you have files there other than the .c source files, try to remove them, restart Open-AT and compile.

Good luck!


#4

Unfortunately this does not help, in my case there are no other files then the .c source files in the src folder.

So the problem is still unresolved, as far as I know.


#5

I’ve got the same problem!
How can I solve that?

Alex Teixeira Benfica
palpitedigital.com.br


#6

Hi, I had the same problem once.

Try running the “Re-build all (Target)” command in Make Targets tab (on Eclipse platform). If this solves your problem please let me know!

Regards from Argentina :wink:

Pablo.


#7

Besure that you have no spaces in any of the file names!

In particular, if you use Windows explorer to drag & drop ‘file.c’ it will give you ‘Copy of file.c’ - and that will mess up the Wavecom build system!

(in fact, I think it causes 3 entries in the project - ‘copy’, ‘of’, and ‘file.c’!)


#8

Thank you all for the tips!

Unfortunately none of them worked, so the problem is still unresolved.

Pablo:

I know, it does compile in Target mode, but I want to use it in RTE mode.
(“Build(RTE)”)

awneil:

I’m trying to compile a sample from the OpenAT CD, called InternetConnection, so the file names are OK.


#9

I’ve exactely the same problem and “Re-build all” doesn’t solve my problem. I use the programme Ping_Gprs provided with the open at’ s CD


#10

It’s a known problem that you can’t make WIP applications with RTE target with Eclipse (at least it is listed as such in the last release notes I received).


#11

Hello,

in fact, i have the same problem that i describe here :

wavecom.com/modules/movie/sc … =5341#5341

But, if it is written in the last realease note… :frowning: