Wip_berr_gprs_failed


#1

Hi all,

Does anyone know this error?
What does it mean (except that GPRS failed)??

regards,
Gregor


#2

You’re right - it is a really unhelpful code! :angry:

For a dial-up bearer, there’s a whole range of codes indicating specific causes like no answer, number busy, etc - but, for GPRS, there’s just this one amorphous code that covers absolutely anything and everything that could possibly go wrong prior to connecting to the APN. :angry: :angry:

I have just been complaining to Wavecom about this very thing!

As I understand it, the redult could be caused by any of the following:

Which, I think, boils down to:

  • The SIM is not provisioned for GPRS;
  • The network is GSM-only; it has no GPRS capability (do any of them still exist?) or, perhaps, the GPRS is out-of-order;
  • The APN name does not exist;
  • The APN name exists, but refuses the connection.

You should also check, of course, that you are GSM-registered before attempting to start GPRS…


#3

Hi awneil,

Thanks for your explanations, but:

  • the device has an transmission interval of 1hour
  • it was working before
  • failed about 5 times
  • it is working afterwards
    Same behaviour on several devices.
    All prerequisites are met (GSM registered, etc.)

So the conclusion would be that some error exist at the GSM network.

regards,
Gregor


#4

Or at the APN.

That’s my point to Wavecom: we need a far more detailed set of error returns to be able to identify precisely where the failure is occurring!


#5

I agree.


#6

You can also get WIP_BERR_GPRS_FAILED as the reason for a WIP_BEV_IP_DISCONNECTED event when the bearer fails after being successfully established…

eg, if the SIM is removed while the bearer is active.


#7

i am facing the same problem. And it really gets annoying me. If any solutions or ideas found pls share here.
thanks


#8

hi.
i have the same problem too. i think many people get this error (if it is an error). there must be a description for that.
In my problem, i reset the modem with cfun=1 immediately after i get WIP_BERR_GPRS_FAILED event message. Obviously it doesnt solve the problem. after reseting, it tries to connect gprs again but WIP_BERR_GPRS_FAILED event message is received again. this continues untill sometimes 10 tries , sometimes 20.
i read some comments on other topic. some said using cfun=0 before cfun=1 should solve the problem but it didnt help me when i tried it.
So any solutions or ideas will be very helpfull for us to get this problem over.


#9

Like I said earlier, there are very many different things that could possibly cause WIP_BERR_GPRS_FAILED - so there can never be one single solution!

That’s why it’s so important to have proper result codes that precisely identify the nature of the fault - so that appropriate recovery action can be taken!

You really need to investigate precisely what is causing your particular problem; eg, if you have very poor GSM coverage, then frequent failures are obviously to be expected!


#10

This error wil receive when sim card circuit is not working,You can check by making voice call or sms to ensure sim circuit,if sim circiut is Good then it is not a GPRS enabled sim.

regards,
Raja


#11

Again, that is just one thing that might cause WIP_BERR_GPRS_FAILED - there are also many others!

That would still not distinguish between a faulty SIM and no GSM service, for example!

No, that is not necessarily true.

You could have a good GPRS-enabled SIM, properly inserted, and still get WIP_BERR_GPRS_FAILED; eg, if there is no GSM coverage, or you got the APN wrong, or…

Again, this is why WIP_BERR_GPRS_FAILED is such a worthless code - we really need a proper set of codes that directly gives the precise reason for failure! :angry: :angry:


#12

i agree with you. there are many possible errors but there is only one message.
so there is no chance to discover the thing which causes this error. we can only make a guess to find the error evenif you dont know the solution.


#13

No, that’s not true.

You need to devise a sequence of tests to determine where the problem actually lies; eg,

  • You can determine that the SIM is correctly inserted & working by monitoring the +WIND indications;
    you can also try any AT command that accesses the SIM - you will get a CME error if there’s a problem.

  • You can determine if you have GSM service with +CREG, and check signal level with +CSQ

  • You can determine if you have GPRS service with +CGREG

etc, etc,…

Don’t guess - test!

But it would still be better if Wavecom provided the information directly! :angry: :angry:


#14

i agree.
i wonder if any wavecome stuff follows this forum.i think it can be usefull for wavecom finding the bugs in their modules by following the forum topics.


#15

Have the same problem…
SIM OK CSQ > 12 CGREG 1,2… so should work and hase but suddenly it won’t work annymore for some? reason…
Get function return error -52 at this function

Ret_Open = wip_bearerOpen(&Br_Id,“GPRS”,BearerHandler,NULL);But can’t find the meaning of this error… Is there somwhere a list off this response codes??


#16

No, that is not the same problem!

-52 is not WIP_BERR_GPRS_FAILED !

Yes: it is at the end of the WIP User Guide - in a section titled, funnily enough, Error Codes”! :unamused:

Unfortunately, the meaning of error code -52 is not listed:
Are you sure that’s correct?
How did you determine it’s -52?

Do you get any other clues in the Trace?


#17

Ok mistake was made… had wrong response code…

= -20 response to the function above.


#18

And have you looked-up the meaning of that code…?


#19

Yes thanks to the “rtfm” tip above…
For some reason “The device does not exist” ? (error -20)
Need to read more in that document to have a clou about the meaning of “device”
Start tomorrow fresh on it. Have no clou yet application worked before…
Seems to be an error in my software somewhere…
Probably an initialisation error or call to the function at the wrong moment…


#20

Yust to let know something witch works… after strugling…
Was at they end a faulty IP number …

        wm_sprintf(APN,"%s","office.vodafone.nl");
        wm_sprintf(APNUname,"%s","vodafone");
        wm_sprintf(APNPwd,"%s","vodafone");
		/*set the option for the bearer service */
        Ret_Option = wip_bearerSetOpts(Br_Id,WIP_BOPT_GPRS_APN,APN,
			                           WIP_BOPT_LOGIN,APNUname,
						               WIP_BOPT_PASSWORD,APNPwd,
						               WIP_BOPT_END);