Windows 7 x64 installation failure


#1

I’m trying to install “OpenAT Software Suite 2.31 - FullInstaller” under Windows 7 x64 version. I’m getting the following error (retrieved from the log) and i can’t continue to perform a successfull install:

[i]!SESSION 2010-03-17 12:23:28.353 -----------------------------------------------
eclipse.buildId=unknown
java.version=1.6.0_17
java.vendor=Sun Microsystems Inc.
BootLoader constants: OS=win32, ARCH=x86, WS=win32, NL=it_IT
Framework arguments:
Command-line arguments: -os win32 -ws win32 -arch x86

!ENTRY org.eclipse.osgi 4 0 2010-03-17 12:23:31.919
!MESSAGE Application error
!STACK 1
java.lang.RuntimeException: Application “com.anwrt.p2.installer.application” could not be found in the registry. The applications available are: org.eclipse.ant.core.antRunner, org.eclipse.equinox.app.error, org.eclipse.equinox.p2.artifact.repository.mirrorApplication, org.eclipse.equinox.p2.director.app.application, org.eclipse.equinox.p2.director, org.eclipse.equinox.p2.garbagecollector.application, org.eclipse.equinox.p2.installer.application, org.eclipse.equinox.p2.metadata.generator.EclipseGenerator, org.eclipse.equinox.p2.metadata.repository.mirrorApplication, org.eclipse.equinox.p2.publisher.InstallPublisher, org.eclipse.equinox.p2.publisher.ProductPublisher, org.eclipse.equinox.p2.publisher.FeaturesAndBundlesPublisher, org.eclipse.update.core.standaloneUpdate, org.eclipse.update.core.siteOptimizer.
at org.eclipse.equinox.internal.app.EclipseAppContainer.startDefaultApp(EclipseAppContainer.java:242)
at org.eclipse.equinox.internal.app.MainApplicationLauncher.run(MainApplicationLauncher.java:29)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:110)
at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:79)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:368)
at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:179)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
at java.lang.reflect.Method.invoke(Unknown Source)
at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:559)
at org.eclipse.equinox.launcher.Main.basicRun(Main.java:514)
at org.eclipse.equinox.launcher.Main.run(Main.java:1311)

!ENTRY org.eclipse.osgi 2 0 2010-03-17 12:23:31.932
!MESSAGE One or more bundles are not resolved because the following root constraints are not resolved:
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-17 12:23:31.932
!MESSAGE Bundle reference:file:plugins/org.sf.feeling.swt.win32.extension_1.0.5.jar was not resolved.
!SUBENTRY 2 org.sf.feeling.swt.win32.extension 2 0 2010-03-17 12:23:31.932
!MESSAGE Missing host Bundle-NativeCode_0.0.0.

!ENTRY org.eclipse.osgi 2 0 2010-03-17 12:23:31.934
!MESSAGE The following is a complete list of bundles which are not resolved, see the prior log entry for the root cause if it exists:
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-17 12:23:31.934
!MESSAGE Bundle com.anwrt.p2.installer_1.0.2.200912171336-R3437 [2] was not resolved.
!SUBENTRY 2 com.anwrt.p2.installer 2 0 2010-03-17 12:23:31.934
!MESSAGE Missing required bundle org.sf.feeling.swt.win32.extension_1.0.5.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-17 12:23:31.934
!MESSAGE Bundle com.anwrt.p2.installer.builder_1.0.2.200912171336-R3437 [3] was not resolved.
!SUBENTRY 2 com.anwrt.p2.installer.builder 2 0 2010-03-17 12:23:31.934
!MESSAGE Missing required bundle com.wavecom.openat.ide.installer_1.0.2.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-17 12:23:31.934
!MESSAGE Bundle com.wavecom.openat.ide.installer_1.0.2.200912171336-R3437 [5] was not resolved.
!SUBENTRY 2 com.wavecom.openat.ide.installer 2 0 2010-03-17 12:23:31.934
!MESSAGE Missing required bundle com.anwrt.p2.installer_1.0.2.
!SUBENTRY 1 org.eclipse.osgi 2 0 2010-03-17 12:23:31.934
!MESSAGE Bundle org.sf.feeling.swt.win32.extension_1.0.5 [88] was not resolved.
!SUBENTRY 2 org.sf.feeling.swt.win32.extension 2 0 2010-03-17 12:23:31.935
!MESSAGE Missing host Bundle-NativeCode_0.0.0.[/i]

The installation was successfull on Windows XP 32bit version. The problem is on Windows version or 32/64 bit version of seven ?


#2

Hi, I have the same problem, but I can answer you that the problem is 64 bits, I have the Full installer working fine in a 32 bits Win 7. I still looking for a solution for 64 bits.

Hope this helps…

DiegoM


#3

:question:


#4

Yesterday I installed OpenAT Software Suite 2.34 Full-installer under 64-bit Windows 7. Following the advices in this forum, I installed 32-bit Java, not 64-bit. First installation failed similarly as described by phrozzy. Then I disabled the firewall in the Win7 and tried to install 2-nd time. After filling information in some dialog windows, the installation run about 7 minutes without having any window on the screen :open_mouth: . Nevertheless, after 7 minutes a window announcing successful installation appeared. I am not sure, if there is any connection between disabling the firewall and the success of the installation.


#5

Awneil, how do i change those command-line arguments? I tried to run installation from command prompt without success, and i can´t find where to change them from the file properties. Anyway, first i{ll try disabling firewall as phdesign said. Let´s see what happend. Thank you very much!


#6

I have no idea!

I just noriced the 32/64 discrepancy - it may not even be significant!


#7

Ok, it works. JRE 32 bits installed (not 64 bits version), windows firewall installed, run installer as administrator and seleck the local package install option. At first run it shows last updates for installing. Then install Java 64 bits and SDK still running fine. Finally activate firewall again, and SDK runs OK. Thank you for the hints!