Why I cannot see user LED selection in Resourse

I bought FX30 with WP7702 module. I can register it to Octave.
To check LED operation, I performed 1-7 operation on “2. Commanding Resources” in the following URL.

But I did not see green and led resource in Resource windows.
I can see any value in io/config. To see two resource making Service, what part should I check Octave or FX30?

Hello Takashi,

You should see these resources.

You configure these via Services → GPIO

See this forum entry:

I hope this solves your issue.

You can find usage information on FX30 LEDs here:

Thanks, But I did not see green/red in my Resources. My process is:

  1. Set GPIO output for LED_USR_GRN and LED_USR_RED
  2. Go to Resources screen and check io note.
  3. But I did not see green and red1 node. Please see my screen and advise next confirmation.
    Note: I use FX30 with WP7702 module now.

Hello Takashi,

I believe there is a bug in the Octave UI. If you use anything other than the default:
“name”: “LED_USR_GRN”,
"res": “LED_USR_GRN”,
“type”: “DO”
“name”: “LED_USR_RED”,
"res": “LED_USR_RED”,
“type”: “DO”

The LED resources will not appear in the resource tree unless you use the default names… Please use the default names now for a workaround to the issue. I will submit a ticket to engineering

Highly recommend you upgrade FX 30 device to firmware 3.2.0 or higher. This issue appears to have been fixed.

Thanks. I tried to update Octave 3.3.0 from 3.1.0.
I select Firmwares in DEVICE->details and select 3.3.3 and press “DEPLOY” button.
I think that FX30 tried to update FW by FOTA. But… FOTA did not finish after 3 hour. Module signal is stopping for 1 hour.
How to recovery this behavior.

I connect USB cable and send AT command. Then, module returned the attached file response. I think that FOTA is succeeded but carrier image is difference. So, FX30 cannot connect network and Octave cannot receive correct information from FX30.
I’m using FX30 on Japan. So, I would like to set default image for Octave. Please let us know how to recovery it.
My FX30 SKU is 1104665.

I attached Log file, please advise it.AT_commad_log.txt (2.6 KB)

Hi Takashi-san,
The log you attached shows the device has received the ATT 3.3.0 binary, whereas it should be SIERRA 3.3.0.
I need to check with the Octave back-end team why this happened. Do you use an ECC SIM card ?
Meanwhile you can recover your FX30 by updating it locally:

Please select the 3.3.0 FX30 version (not the ATT one)

Hi Takashi-san,

Our system (Airvantage) indicates that you are using ATT network in Japan, with an ATT sim card. This is why the system picked up the ATT Firmware version.

Can you explain how your offer works ? Why should you not use the ATT APN ?


After updating FW for SWI, I can control user LED.
When I control LED_USR_GRN for GPIO48, FX30 is changed Red.
When I control LED_USR_RED for GPIO47, FX30 is changed green.
Why my environment is mixing LED control between Red and Green?
I used latest FW 3.3.0 now.

Hello Takashi,

Please see this link for controlling FX30 LED colors: