Uninstalling old gl6110 USB driver

A customer had his laptop stolen and bought a new one with Win8.1 installed.

He has a GL6110 and I installed (foolishly) an old driver which failed to work (I have little experience with WIN8).

I then downloaded the latest driver but it failed to uninstall the previous driver.

I tried to uninstall using Windows Uninstall. This appeared to work but the drivers were still in place.

I then tried to delete the files in ProgramFiles but some were held by running programs or services.

There are no Sierra services or programs apparent, either in Autoruns or in running drivers.

Does anyone know how to get completely rid of the drivers that I may install the one that will work with WIN8?
What name are they under in the registry or autoruns?


Hi Dermot,

Which driver you installed and planned to install?

Does system restore works?

I haven’t try but I think we can show all devices via setting registry:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager\Environment]

Then we can find the old driver in device manager and uninstall it.

Hope this helps.

Thanks Lotam

The driver I first installed was “USBDriverInstallerV3841” and then tried the current one “USBDriverInstallrV3860” but it failed to install.

I will try to set “DEVMGR_SHOW_NONPRESENT_DEVICES”=“1” and see what I get.

Do you know the name of the services or of the registry entries for Sierra Wireless?