Help, USB drivers, windows 8 airprime Q2687


I’ve tried a number of different drivers from the sierra wireless site for USB drivers and absolutely none that I try seem to work for windows 8.

I cannot get my computer to acknowledge that there is any devices. Has anyone else had this problem or know of which drivers worked for them with windows 8?

Thanks, I’d really appreciate the help.

Hi kki036,

Does your Q2687 work on Win7/WinXP?

Does it prompt and ask for driver on Win8?
Also, have you try this one?


Yes that was my second try, and I tried uninstalling everything and re-doing it with that one and I still get the same issue.

Everything installs no problem, but when you plug in the device it does nothing. No prompt. No nothing.
However when you install the USB driver it doesn’t say there is any issues, even appears in my control panel, but when you click on it to do something with it it says no driver installed. :angry:

I think I have officially tried everything I can think of.
I’ve tried all my USB ports on my computer, I’ve tried uninstalling and re-installing all the drivers. re-tried all the ports. uninstalling and re-installing the program, and drivers. I’ve tried compatibility mode in windows 8. I’ve looked in every settings thing I could find in my computer looking for any hint of it being there, and I can’t find anything in my computer that sees it’s existence.

Still i get the error of saying there are no drivers installed on the system, for seirra wireless serUSB.

I’m also installing the drivers in the Sierra wireless folder.


i have the same problem with an 64bit Windows 7. Did you succeed in resolve it?

Hi kki036

I have the same problem, only now it’s with win 8.1.

Was your issue resolved.




I am seriously movig out from Sierra Wireless modem. We did a test environment with 4 modem stations, before to install more 40. No one from these 4 are 100% ok since the begining of the tests.

Also the support is not good, and the compability is very limited.

I have the same problem with windows 7 64bit. No driver installed works, even if they are downloaded from the proper Sierra page

Any updates for anyone else with this, I have the same issue with Win7. Sierra support told me to check the forum - replied I had and had seen this thread with no tech help from the company. Needless to say waiting a response from that email…

Hi all,
Could you please check if the USB port of the Q2687 module is enabled? You can trying issuing AT+WMFM=0,1,3 command and then try connecting the PC with module over USB port.

Also, have you created any Open AT application (using Open USB feature) which may be internally using the USB port (this may occur if you have downloaded the EEM sample application in the module which locks the USB port and makes it work as a virtual Ethernet card). You can issue AT+WOPEN? Command to see if the response to this command is +WOPEN: 0 or not (if it is +WOPEN: 1, then try issuing AT+WOPEN=0 command and then again try to connect the module with the PC over the USB port).