Unable to run DWL Win


#1

When I try to run DWL Win (version 4.1.6.6) as downloaded from the web-site I get the error “Program too big to fit in memory”. Before anyone posts saying that this is a RAM issue, I have tried it on 3 machines including a high-end dual-core laptop with 4GB RAM. I am completely stuck. Any help is appreciated.


#2

What program?

Is that Windows telling you that the DLWin program is “too big”, or DWLWin telling you that the Open-AT “program” is too big?


#3

This is what I get when I run DWL Win from the command line - with no parameters. The program does not run at all and I cannot even get to the associated Windows GUI to put in any parameters.


#4

Could it be a corrupt file (EXE or DLL)? Maybe redownload and try again? Or download an older version?


#5

I’ve tried redownloading with no luck, so maybe I need to get an older version, but from where?


#6

Go to the downloads page (where you see the tree of files). In the upper right corner is the “Archives” link. This lets you go back to older versions.


#7

I tried v4.1.6.5 which gave me the same response, v4.1.6.3 which gave me the same response, and finally v4.1.1.0 ran. However, running v4.1.1.0 only succeeded in giving me a “Boot failure: cannot connect with the target” error, which was strange given that every other serial communications program can connect to the device. Help, I have been looking at this for days and at this stage the Wavecom device is functioning as an expensive paper weight!

PS I have tried all the exes on 3 different Windows XP machines and a Windows Vista machine so I have no idea why it won’t work!!!


#8

If you will download a binary to the target using DWL Win you must close the boot Jumper and press reset because the target must be in a special mode.


#9

This problem has been solved!!!

The file for download on the website is corrupt (anyone from Wavecom reading this should fix it ASAP). It has the additional characters

inserted at the beginning of the binary file (check for yourself with a hex editor). Remove the offending bytes (including the newline) and the binary installs as expected.


#10

For the uninitiated (i.e. me) how do I do this (as I now have the DWL Win application running)?


#11

What browser are you using? I downloaded versions 4.1.6.6 and 4.1.6.5 and read them with a hex editor. They both looked fine for me. (I’m using Firefox 1.5.)

Hmm… I don’t have a Fastrack Supreme, so I’m no expert, but a quick review of the documentation seems to indiate that, unless you have a custom IESM (expansion card) that can short the BOOT signal to 1.8V, then there’s no way to use DWLWin. Perhaps if you take the Fastrack Supreme apart, there’s a test point or something that you can poke at. That’s not documented.

But if all you’re trying to do is update the firmware, you may not need DWLWin at all. You should be able to just use AT+WDWL (I haven’t tried updating to the latest firmware, so maybe I’m wrong, but AT+WDWL worked for older firmware.)


#12

That is certainly what my Distributor told me - but others on this forum do claim to have used DWLWin with the Fastrack Supreme.

The documentation on this point is, as you say, really poor! :frowning:

Again. :angry:


#13

I tried using Firefox 3 and Internet Explorer 7 yesterday, on two different machines, running Windows XP and Windows Vista. I will try again today.


#14

It is definitely the file on the website - I tried again with Opera and Safari, with the same results (a corrupted file).


#15

Sorry, but I’ve experience with quick modules only. But one of my colleagues had had the same problem with a fastrack or a fastrack supreme several years ago. To solve it he must open the case and connect one pin of the D-SUB-15 connector with ground. Because he don’t know which pin he connected you should ask your distributor.


#16

Perhaps you should email webmaster@wavecom.com with this? They should be able to check this pretty quickly.


#17

The handling of the BOOT pin is completely different between Fastrack and Fastrack Supreme.

For the Fastrack, it was clearly documented; :slight_smile:
For the Fastrack Supreme, it isn’t. :angry:

No! That is wrong!

For the Fastrack, the Boot pin is clearly identified in the Manual, and accessible without dismantling.

For the Fastrack Supreme, grounding it does not work (I’ve tried it); possibly connecting it to 1.8V might work, or it might just not be connected at all (as my Distributor says) - the manual is not clear about this :angry: :angry: