ULPM on FX30

I followed the Octave document below to set ULPM on FX30 (FW 3.0.2), but run into weird situation.

I set timer to 120 sec.

Then, I added an event in command stream to trigger ulpm
image

After about 30sec, FX30 did power down. The LED went off. I waited for more than 120 seconds and the FX30 did not wake up. FX30 never wake up even after more than 5 minutes’ wait.

Then here it comes the weird part. I cycled the power and FX30 did power up. But it power down again in about 60 second. I couldn’t do anything from Octave dashboard to bring it back to normal operation because it kept shutting down.

I added an observation /util/ulpm/value.timer to trigger an EA to disable ulpm. But it didn’t help.
function(event) {
return {
“dh://util/ulpm/shutdown” : [false],
}
}

at!powermode? showed status=2 (Enable PSM) from console. I have to use at!powermode=0 to disable PSM to bring FX30 back to normal.

Can anyone tell me what I did wrong or missed any steps? How can I correctly set ulpm from Octave dashboard or EA?

Hi James,

I have similar problems and as I did not know of the AT command you mentioned I ended up flashing a new image using swiflash from a PC to make it stop. I think it would be nice if the at!powermode=0 command was mentioned on the ULPM documentation page as a lot of people will need it. Can the same be done from the command line via ssh in any way?

I too still haven’t found a solution to the boot loop problem.

Since I couldn’t get anything changed through Octave, I use ssh to check and found the powermode is 2, which is PSM mode according to document.

New 3.1.0 FW seemed to fix this problem. I was able to use ULPM correctly on FX30S after FW upgrade.

ULPM works well on FX30S after 3.1.0 FW upgrade. However, when ULPM command is send from Octave Dashboard to FX30, FX30 enter PSM mode. I was expecting FX30 and FX30S should behave similarly with new FW. But it is not. Looks like another FW is needed for ULPM to work on FX30.

Hi James, I will test ULPM on both device types in 3.1.0. The functionality should be identical. If it is not, I will report the bug.

I tested ULPM on one FX30S and two FX30. Before testing ULPM, I factory reset FX30, set {“timer”: xxx} to ulpm/config on Octave and issue command from ulpm/shutdown. FX30S wake up after time out as expected. Both FX30 went into PSM when ULPM command was issued.

Hi James, I tested FX30s with ULPM and they both went into ULPM and wokeup at the prescribed timer event

Hi, David,
Yes. FX30s (RS232 version) was OK. But FX30 (Ethernet version) went into PSM mode instead of ULPM. Please try it on FX30.

Hi James,
I tested on 2 FX30’s type Ethernet with success

On FX30, when I changed ulpm timer setting from 600 to 180 in Octave
util/ulpm/config {“timer”:180},
AT command “AT!POWERWAKE?” confirmed the change for ULPM TIMER.

However, there is “PSM TIMER:180000, ACTIVE TIMER: 20, SYNC: 2” response from FX30 where FX30s doesn’t show this.

When I issued shutdown command from Octave { “util/ulpm/shutdown”: 1 }, the AT!POWERMODE showed status changed from 9 to 8 (PSM disabled -> enabled) on FX30. FX30s went into ULPM before I can get response with AT!PWOERMODE? command.

Not sure why my FX30 and FX30s behave differently.

image

I forced FX30 to disconnect from network by removing antenna. I use AT!powerwake=1,90,90,2 to set ULPM timer and AT!powermode=3 to make FX30 enter ULPM. FX30 was able to wake after 90 second.
After FX30 wake up, ULPM timer get changed to the timer value set by Octave (85 sec). PSM TIMER became 180000. AT!powermode=3 made FX30 enter ULPM again and wakeup after 85 sec. I can repat this without problem.

The, I plugged antenna back in to FX30. After Octave detected FX30 is back on line, FX30 went into PSM mode couple seconds later automatically.

I have a few questions.

  1. Where to set PSM TIMER in Octave?
  2. What would make FX30 enter PSM mode? Anyway to disable PSM mode from Octave?
  3. When FX30 is not connecting to network, ULPM seems to work as expected by AT command. But once it is connected to Octave, ULPM doesn’t work. Why?

Hi James,

I am not sure if this answers your questions but I had similar problems.

I found this thread here:

…which explained how to turn PSM off, with AT+CPSMS=0 (not with an exclamation mark as shown in the preview).
Apparently it solved the problem of the FX30S entering either ULPM or PSM when the antenna was connected.

AT+CPSMS?
+CPSMS:1,“00011000”,“00001010”
AT+CPSMS=0
OK
AT+CPSMS?
+CPSMS:0,“00011000”,“00001010”
OK

I have only been using ULPM from Octave and pmtool from the command line so I have no idea how PSM have been enabled.

Thanks for the suggestion, jj1.

This is the result from my FX30
image
AT+CPSMS showed PSM is disabled. But AT!powerwake show PSM Timer is set to 14400.

The following is the result from my FX30S
image
The AT!POWERWAKE? only show the ULPM Timer, not PSM TIMER.

Not sure why PSM Timer is set on FX30, but not on FX30S. The behavior on FX30S is what I would expected. Still need help on the FX30 ULPM issue.

I have done a sequence of tests on FX30 (FW: 3.1.0). The following result is really confused me.
Test#1:
Set wakeup timer to 60sec (AT!powerwake=1,60,60,2)
Set power mode to ULPM (AT!powermode=3)
image
Result: FX30 enter ULPM successfully ans wake up after 60 sec

After wakeup from ULPM, the ULPM Timer was changed to the setting I set in Octave. PSM Timer got changed to 300sec. (not sure how this timer was set?)


image

Test#2
Use AT!powermode=3 to make FX30 enter ULPM again without setting powerwake.
This time FX30 wakeup after 180 sec according to the ULPM Timer.
AT!powermode & AT!powerwake result stay the same.

Test#3
I use Octave to send ULPM shutdown command
image
FX30 did not enter ULPM mode this time.
I used AT command to check and found the PSM Timer got changed again to 3240 sec. And power mode status showing status=8, PSM enabled. (head scratching???)
image

Test#4
Use AT!powermode=3 to make FX30 enter ULPM again
FX30 enter ULPM & wakeup after 180 sec.
After wakeup, status=2-Initialized
PSM Timer got changed to 1320sec.
image

Test#5
Use AT!powermode=3 to make FX30 enter ULPM again
FX30 enter ULPM & wakeup after 180 sec.
After wakeup, status=2-Initialized
PSM Timer got changed to 1320sec.
image

Test#6
Use AT!powermode=3 to make FX30 enter ULPM again
FX30 enter ULPM & wakeup after 180 sec.
After wakeup, status=2-Initialized
PSM Timer got changed to 3240sec.
image

PSM Timer change to random number every time. But AT!powermode=3 can set FX30 to ULPM and wake up according to ULPM Timer.

So the problem is why using AT command can set FX30 to ULPM, but not Octave.

1 Like