ULPM on FX30

My FX30S is connecting to Chunghwa Telecom Cat-M1 network in Taiwan.

Hi, my operator is Telenor (Denmark).

I hope that it helps. :slight_smile:

Hi Jes, James,
Thanks for your feedbacks.
We’ve confirmed the issue we were suspecting.
When ULPM is triggered, the PSM is enabled in the device by default with fallback strategy on ULPM so that if the network supports PSM then ULPM is never actually used.
We’re planning to fix this configuration issue in next 3.2 RC6 coming within 2 to 3 weeks.

Hi, Cédric,
That’s great. Looking forward to test with the new release.


That sounds really great. As you have identified the source of the problem, can you perhaps provide a workaround for the existing firmware revisions?
This bug has really delayed our development and if we could have a workaround we will save a couple of weeks.


Hi all,

Unfortunately, if in your solutions you are using Octave ulpm/shutdown resource to enter ULPM, then there is no immediate workaround.
However, if you are able to issue a Linux command, then a workaround is to directly write to the kernel swimcu sysfs nodes:
echo 6 > /sys/module/swimcu_pm/boot_source/enable
6 value will allow to enter ULPM only and not PSM.


Hi Nicolas,

Thanks a lot. Can you by any chance come up with a trick to execute shell commands based on something in Octave? I imagine a shell script running on the FX30 monitoring a resource using dhub or something more elegant. I don’t have the Legato build chain setup up and I really don’t know much about it.


If future Octave FW could add a resource for developer to send Linux or AT command, that would be a great tool for troubleshooting and issue work around in the future.

After Octave ulpm/shutdown command, I used AT+CPSMS=0 to disable PSM then FX30 can enter ULPM. Therefore if there is a resource where I can issue AT command, I can have a quick fix with Edge Action before the new FW is ready.

1 Like

3.2.0.rc6 is just out and should be available in your company for FOTA.
It should fix the ULPM issue.